Seed Ratio 0 overrides Seed Time - Transmission

Docker: sonarr transmission 4.0.5

How can I make sonarr remove torrents in Transmission after a certain amount of time seeding?

If I set indexer Seed Time 1 and leave Seed Ratio empty the torrent seeds for 1 minute, pauses but is never removed.

It just shows as grey and “Seeding complete”.

If I set Seed Ratio 0 and Seed Time to whatever the torrent will immediately pause and be deleted ignoring Seed Time. This confirms I don’t have a permission issue since sonarr can obviously remove torrents.

Stop seeding at ratio: and Stop seeding if idle for N mins: are both disabled in Transmission.


Set ratio to 1000 to ensure seed time will be satisfied first, see if that works.

I tried it and the behavior was the same.

Screenshot 2024-01-14 at 05.36.41

Sonarr removes media from the queue once it is copied over from the download client so it stops monitoring at that point. I believe if the seeding requirements are satisfied at the point it relocates the media it will clean up the download client (which is why when you set the seeding ratio to zero it will stop and remove it) but if the seeding requirements are not met when the Sonarr processes the media and removes it from the queue you are out of luck.

My question remains, can I make sonarr remove torrents in Transmission after a certain amount of time seeding?

All I care about is time, not ratio.

One of the developers will have to answer if they look at seed time as well as ratio when they determine whether to clean up a torrent or not. Based on your own experimentation it appears not. Also, from a purely practical perspective I doubt that they do since Sonarr checks the download status every two minutes and the longest it would likely take to copy/move media from the download client to the Sonarr file system is probably about a minute meaning that if your seed time was set for 3 minutes or more you would likely remove it from the Sonarr queue prior to the seed time being satisfied anyway. I could be wrong about this entirely but I suspect that is how it works.

If a dev could answer that would be great.

I just tried Transmission 3.0 and the file is deleted with the same settings!

I will report this on the Transmission github.


Screenshot 2024-01-14 at 20.07.40



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.