Season pack downloads


#1

Sonarr version (exact version): 3.0.1.411
OS: Windows 10
Debug logs: https://drive.google.com/open?id=1B9zJ6XCB0XzTZfCMHwAh2WTsuwWJPygx
Description of issue: When downloading season packs only the first to third episodes are copied over after downloading.


#2

That’ll happen if you’re exacting or copying files into the directory that Sonarr is set to import from and the download client indicates the download is complete before the extraction/copy is complete. Not an issue with local usenet clients, but is a problem with local/remote torrent clients.

The work around is to extract/copy to another folder then move the files into the folder where Sonarr expects to import from, which should happen instantly on the same drive.


#3

Thanks for the update.

I’m being dumb here, but how would I do that if I’m currently syncing the completed downloads folder from a seedbox to a local folder where sonarr processes the files. Do I have to change anything in sonarr itself?


#4

Either sync them to a different folder and once the sync completes, move them to the folder Sonarr is looking at or use Sonarr’s API to tell it to import after the sync (one call per torrent, not per file).


#5

Where do I set it to one call per torrent, not per file. Is that within sonarr or resilio sync? Can’t seem to find the option for that in either program.
Sorry for the constant I’m assuming easy questions, but I’m completely lost and new to all of this.


#6

It’d be with whatever you use to tell Sonarr to import the file, I was paraphrasing what the wiki page says about that API endpoint.

You’re probably better off syncing to another directory then moving the files once resilio is done (assuming it can execute a script once complete).


#7

Couldn’t get their api to work since I believe its for developers, so I ended up using a powershell script to move files from the sync folder every 15 minutes to the local path folder set in sonarr. Problem now is, completed downloads are not bein moved despite being in the correct folder. Just staying in the queue with - No video files were found in the selected folder message. I then tried putting everything back to the way it was, same result.


#8

That’ll happen while the files aren’t in the folder Sonarr is expecting them in, but it should detect the change within a minute or two of them being dropped in there.


#9

It’s been a couple of hours now, still no change. Any ideas?


#10

Double check the paths and permissions, beyond that I don’t have any ideas.


#11

All fixed now. Folders were set to read only. :expressionless: :sweat_smile:

EDIT: Spoke too soon, doing the same thing again. :cry:


closed #12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.