RSS using too many API calls all of a sudden

I’m running Sonarr using the linuxserver Docker, updated to version 4 in January and have been having no issues until a week or so ago when I suddenly started to exceed my API limits. I’m only using the free plan on a couple of indexers and so use one for RSS and one for manual searches.

I notice now that, when I run an RSS search the API hits quickly go from 1 to past my limit of 25 in a few seconds and then the RSS fails because the API limit is exceeded. I can see the number of API hits climbing on my profile page on the indexer site as soon as I hit the button.

I thought an RSS search should only use 1 API call, so any ideas why this might be happening? I tried the other indexer and the same occurs, so it isn’t an indexer issue.

Running a text on the indexer setup page in Sonnarr only generates 1 API hit as you would expect.

I’m baffled - please can anyone help?

Provide the information requested in the template you deleted, including debug logs.

Sorry, I provided all the info I could (apart from the exact version, my bad), just not in the template format.

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows): No idea sorry, where would I find this?
OS: Docker - linuxserver version, running on Synology
Debug logs:

I have turned the debug logs on but cannot reproduce the issue as I have run out of API hits for today :frowning:

While I wait to tomorrow to generate the logs, can you please tell me if there are supposed to be times when an RSS search will generate multiple API calls - maybe this is within the bounds of normal behaviour and I’ve just been lucky up until now.

No need for the debug logs as I’m fairly sure that this is exactly the same issue that I have, so it would actually be working as expected if so:

How can I limit the number of pages for RSS sync, or reset the “last release found” date : r/sonarr (

Is this true though? Does Sonarr try to catch up when it has been turned off for a few days (which mine was too) and so downloads multiple pages from the RSS at one API hit per page? If so, should deleting and then recreating the indexer solve it, or is there anything else that can be done?

you could always just try disabling that indexer for RSS then re-enabling it

Thanks, but I tried that already and it made no difference unfortunately.

It does seem to be fixed now since I deleted the Indexer completely and then re-created it, as that Reddit post suggested, but it would still be good to get confirmation from someone who knows how Sonarr works that it isn’t somehow co-incidence and that it is the way that it is supposed to work.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.