Rootfolder problem / library management problem

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows): 6.0.13
OS: Ubuntu 22.04.4
Debug logs: PrivateBin
Description of issue: Rootfolder problem / library management problem

Hello guys,

First time here, hope informations provided are enough and in a good format. Tried my best.

Totally new user of sonarr, i read a lot of things in the wiki and posts. Details about my infra : I have a NAS which have a pretty huge capacity acting so more like a backup / cold medias storage. I have another NAS less storage acting more like hot storage (last and recent medias). After several weeks medias on my hot nas goes to my cold nas. Plex adding in library both NAS medias.

So when i download files it’s on my hot NAS, logs : /Shares/Downloads/ and after several weeks it goes to /Shares/NAS/

Sonarr is working perfectly and move to /Shares/Downloads all the downloaded files. BUT i have mount error as you can see it in my log debug file.
I tried to map both root folder /Shares/Downloads and /Shares/NAS et i wanted to point out the library to both as i can do it with plex so when files moves to cold NAS sonarr is not trying to download it again.

It doesn’t work and when i go to Settings / Media Management and click to one of my root folders i get an Unable to load root folders Error.

Could you help me to find the good way to point both library hot nas and cold nas ? (only one downloads directory i know it’s a question often asked → hot nas) and maybe solve the error that i have in the logs ?

Thanks a lot guys

Sonarr only supports one location for a series, either you need to merge the hot and cold NAS so Sonarr sees it as one or have Sonarr ignore episodes when they are deleted (moved to the cold NAS).