Remote completed file pickup not happening

Sonarr version (exact version): 3.0.3.731
Mono version (if Sonarr is not running on Windows):
OS: Win10
Debug logs: https://drive.google.com/open?id=1LH8OmWeYfksn5DzyMUK99_2hjBKXjcPD
Description of issue:
I’ve looked and tried everything it seems, but I’m determined to get this fixed today. Sonarr can do a manual import perfectly fine, though it won’t do it using the ‘Quick Import’ button. The app is running on a Windows machine on the same network with a Synology NAS running DS where the video library is stored as well. I’ve got the NAS mapped as B: on the Windows computer, and permissions seem fine if Sonarr has no problem moving files manually, so I’m not sure where the hangup is. Here’s my Remote File Mapping Settings currently. I’ve tried different variations of the Remote Path line, with backslashes and without the first and last slashes as well. In History the icon next to the downloads says Episode grabbed from Wherever and sent to Download Station and then it just sits in Wanted/Missing showing a purple bar that it’s 100% completed.

Host 192.168.0.11
Remote Path //Blackbox/Downloads/
Local Path B:\Downloads\

Fixed elsewhere. The Remote Path required \volume1\Blackbox\Downloads.