Possible Bug in v4: Download Client set for Indexer not being automatically attached to an item

Sonarr version (exact version): by [linuxserver.io]
Docker: Yes
OS: Ubuntu 22.04.3 LTS
.NET: Yes (6.0.13)
Database: Sqlite 3.44.2
Debug logs: PrivateBin

Description of issue:

Each of my indexers is assigned to a specific Download Client. When torrents are added to the queue using some of the indexers, the selected download client is not being attached to the queue’d up item, so the download never starts.

I noticed this when items were automatically added to the queue by Sonarr, so I tried to manually search for and add items to the queue, but clicking the download button fails. If I click the “Override and add to queue” button, the download client there shows up as “Default” (which is not one of my client names) and I am able to change the download client to the correct client, then the download is able to start successfully.

Not sure if it’s related for sure, but this has only been an issue since updating to v4. I haven’t changed anything else about my setup or configuration since the update.

Also, it doesn’t seem to be affecting all my indexers, but I haven’t been able to isolate why some work and some don’t.

I’ve tried creating new indexers and download clients, but that hasn’t solved the issue.


Default Download Client:
Default Download Client

Download Client blank in Queue list:
Download Client blank in Queue list

Download Client Not Available shows up after using the “add to download queue” button:
Download Client Not Available

Download Client set in the Indexer:
Download Client set in the Indexer

Manual Download Client Chooser showing the client is available to be selected:
Manual Download Client Chooser

The download client in the Queue is populated when Sonarr gets the item from the download client, if the item is “Pending” because Sonarr couldn’t add it to your download client (which also coincides with the failing when grabbing from Interactive Search

From the logs

[v4.0.0.748] NzbDrone.Core.Download.Clients.DownloadClientUnavailableException: Indexer specified download client is not available

Did you remove the download client and re-add it? That would cause Sonarr to be unable to find the download client because it’s ID would change.

I haven’t removed the old client, I just added another one pointing to the same place to test with. Also created a new indexer and set it to use the new client.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.