Permission/Mapping issues with Synology + Docker


#1

Sonarr version (exact version) : 3.0.1.513
Mono version (if Sonarr is not running on Windows) : 5.20.1.19
OS : Synology, Docker
Debug logs : error below
Description of issue :

Import failed, path does not exist or is not accessible by Sonarr: /volume1/downloads/<media-file-name.mkv>

If I move the files manually via the docker containers terminal it works fine, and the docker container can access and write to all of the directories via terminal, so I assume this has something to do with the permissions of the user “abc” which Sonarr apparently runs on in the docker image, but I can’t find any useful info to help fix this problem.

The docker container has the PUID and PGID set to the “admin” (1024) user and “administrator” (101) group which is the stock user/group on this Synology device.
PUID=1024
PGID=101

The container also has the volumes set as the following:

File — Mount Path — Type

tv — /tv — rw
download — /download — rw
docker/sonarr — /config — rw

It is my first time using a Synology device and I’m not super experienced with Docker containers. I saw another thread like this where the issue was resolved by remote mapping the /download dir, can anyone please guide me on how to do so?


#2

the docker container cant see /volume1

how did you manage to access /volume1 from inside the container if it isnt mapped?

you can create a remote path mapping in sonarr to map /volume1/downloads to /download - i think theyre on the profiles page?


#3

image

Error:

19-6-12 07:18:06.5|Error|DownloadedEpisodesImportService|Import failed, path does not exist or is not accessible by Sonarr: /volume2/Downloads/Seriesname.mkv Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder

I can see everything i download, in Sonarr it’s just the damn Import that doesnt work :frowning:


#4

as per my previous post, except it cant see /volume2, again because its not mapped into the container

the dsm docker gui can only see shared folders, it cant see the underlying /volumeX those live on so they cant be mapped in from there (you can do it if you run it from the command line)

you need to create a remote path mapping for it in sonarr, should look something like this (its under settings > download clients > remote path mappings)


#5

I tried your way still doesn’t work… Even when i do the remote mapping :frowning:

And i keep getting this error:

I still don’t understadn howcome if i do a manual import it works without any problem.


#6

Had similar issue recently with Docker and Synology. Logically nothing changed from what had setup prior but like your situation wasn’t moving files and getting above error. You might check the owner/permissions on the receiving folder are same as what you have PUID/PGID for SONARR. Can use the DSM file manager to check. Can test one series folder first and try a test download and see if moves.

Then if works have it propagate down through all folders to validate permissions and owner. Once reset path permissions and owner seemed to work although going to pay attention to log for awhile because not quite sure it was a permanent fix. Synology doesn’t use a “normal” Docker setup so that doesn’t help things either.


#7

i think its case sensitive, not 100% sure, but you might want to change it to /volume2/Downloads/ (with a capital D)

also, does the URL in the indexer setup for that indexer use the ip address, 192.168.1.51 or a hostname? it has to match exactly whats in that URL

because when you import it, you import it from /downloads (which it can see), not /volume2/Downloads (which it cant)


#8

FINALLY!!

That did the trick… It’s case sensitive… Jesus such a small thing to fix such a big issue!

Thanks a lot for the help @rhom !