/opt/NzbDrone/ Not Installed

Sonarr version (exact version): 3.0.5
Mono version (if Sonarr is not running on Windows): 6.12.0.122
OS: Ubuntu 18.04
Debug logs: NA
Description of issue: After installing Sonarr via the Sonnar Download page instructions, the service does not start. It fails because the folder /opt/NzbDrone/ does not exist (thus the sonarr.service file cannot open NzbDrone.exe).

I have tried apt-get remove sonnar & reinstalled. There are no errors on installation. Why is the sonnar installer not installing the /opt/NzbDrone/ directory?

TIA - Donald

NzbDrone is v2. Sonarr is Sonarr for v3

NzbDrone is dead.

it sounds like you have a service file you made and it did not update.

Sonarr v3 has it’s own service file upon install; was Sonarr v2 running at the time of the v3 install? if so this should have been handled automagically

remove /etc/systemd/system/sonarr.service

PS 3.0.5 is not an exact version

Thanks for the help. You are correct I had an hold service file from a previous attempt of installing Sonarr months ago.

I removed the sonarr.service file and tried reinstalling. A new service file was not created by the installer.

I can run sonarr by executing: mono /usr/lib/sonarr/bin/Sonarr.exe

Where can I find information on how to manually create the sonarr.service file?

PS full version #3.0.5.114, thanks.

Packages install their service files in /lib/systemd/system

if these are need to be edited where dpkg would not satisfy the required changes then an override would be needed.

No service file needs to be created as the v3 package creates it itself.

if you need to reconfigure it use dpkg-reconfigure sonarr

This is covered on the install instructions you must have skimmed too quickly through.
https://sonarr.tv/#downloads-v3-linux-ubuntu

I had tried running dpkg-reconfigure sonarr many times. I get the error:

sed: can’t read /lib/systemd/system/sonarr.service: No such file or directory

That is why I am asking how to recreate the sonarr.service file. :slight_smile:

Thank you,
Donald

I’ve now tried reinstalling sonarr via apt-get install --reinstall sonarr and I get the following error at the end of installation:
sonarr.service is a disabled or a static unit not running, not starting it.

Thanks,
Donald

do an apt remove then an apt install

ok, did that. I am getting the same error at the end of install:

“sonarr.service is a disabled or a static unit not running, not starting it.”

There is no sonarr.service file in /etc/systemd/system/

Thanks

There’s not supposed to be a unit in /etc/systemd/system

What’s the output of:
systemctl cat sonarr
systemctl status sonarr

All is good - sonarr is running with systemctl. Not sure why I was getting the error “sonarr.service is a disabled or a static unit not running, not starting it”.

Thanks everyone!
Donald

As long as systemctl status sonarr shows ‘Loaded: loaded (/lib/systemd/system/sonarr.service; enabled; vendor preset: enabled)’, it’s all good. (enabled = configured to start on boot)