Nyaa Indexer stopped working

Sonarr version (exact version): 2.0.0.5344
Mono version (if Sonarr is not running on Windows): 4.2.3
OS: Ubuntu Server
Debug logs: Unable to connect to indexer: HTTP request failed: [400:BadRequest] [GET] at [https://nyaa.si/?page=rss&cats=1_27&filter=1]

NzbDrone.Common.Http.HttpException: HTTP request failed: [400:BadRequest] [GET] at [https://nyaa.si/?page=rss&cats=1_27&filter=1]
at NzbDrone.Common.Http.HttpClient.Execute (NzbDrone.Common.Http.HttpRequest request) [0x00133] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Common\Http\HttpClient.cs:100
at NzbDrone.Core.Indexers.HttpIndexerBase1[TSettings].FetchIndexerResponse (NzbDrone.Core.Indexers.IndexerRequest request) [0x0004b] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Indexers\HttpIndexerBase.cs:321 at NzbDrone.Core.Indexers.HttpIndexerBase1[TSettings].FetchPage (NzbDrone.Core.Indexers.IndexerRequest request, IParseIndexerResponse parser) [0x00000] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Indexers\HttpIndexerBase.cs:298
at NzbDrone.Core.Indexers.HttpIndexerBase`1[TSettings].TestConnection () [0x0000e] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Indexers\HttpIndexerBase.cs:335

400 Bad Request >Bad Request The browser (or proxy) sent a request that this server could not understand.

Description of issue: I’ve been using nyaa for a couple of years and it’s been working fine until last week. I wasn’t getting my episodes so I log in to sonarr and see a warning that it failed to communicate with nyaa. I test the connection and get error message above. Don’t really know why or how to fix. Any help would be appreciated.

I don’t know why your indexer is using 1_27 as the category, that doesn’t exist. If you try that link in browser you will get the bad request error. Change the cats value to 0_0 or 1_0 and it works fine.

Both your Mono and Sonarr installs are out of date. Update Sonarr to v3 and Mono to something that isn’t 5yrs old.

1 Like

Interesting. That’s always been the value, I even tried setting it a new one and it defaulted to that. Never the less it did work so thank you very much.