Not Enough Free Space On Import - Sonarr says I have 1.4TB free

Sonarr version (exact version): 4.0.4.1491
Mono version (if Sonarr is not running on Windows):
OS: Windows Server 2022
Debug logs:
Full logs: Hastebin

Concerning Line 1: 2024-05-09 20:18:31.4|Warn|FreeSpaceSpecification|Not enough free space (0) to import: \\tsclient\E\Shares\E Drive\Plex\Need Sorting\[Erai-raws] Undead Unluck - 20 [720p][Multiple Subtitle][4843D64D].mkv (561604645)

Concerning Line 2: [v4.0.4.1491] System.IO.IOException: Insufficient system resources exist to complete the requested service.

Description of issue: Sonarr says that I am lacking the resources / Storage space to import episodes that have been downloaded.
Sonarr is running on Windows Server 2022 inside of a Hyper-V Virtual Machine. It has access to my E drive, and the permissions are setup to “Everyone” has “Full Control”. Sonarr, in the system tab, says I have 1.4TB of storage available on this drive. The VM has 8 virtual cores from a Ryzen 9 5950x, and it has a minimum of 16GB of RAM with an allowed maximum of 22GB of RAM. It never goes passed 25% CPU usage or 40% memory usage. Followed a video to edit my page pool in the registry editor, disabled my firewall, disabled my anti-virus/real time protection, restarted the VM and my actual server hardware, and nothing. Nothing seems to fix this issue. Some here recommended that others “disable free space checking”. When I tried to locate the setting, I could not find it. After looking through the Github, it looks like that setting is disabled for us Windows users, so that’s also not an option for me. Does anybody know how to fix this?

{
                        isWindows ?
                          null :
                          <FormGroup
                            advancedSettings={advancedSettings}
                            isAdvanced={true}
                            size={sizes.MEDIUM}
                          >
                            <FormLabel>{translate('SkipFreeSpaceCheck')}</FormLabel>

                            <FormInputGroup
                              type={inputTypes.CHECK}
                              name="skipFreeSpaceCheckWhenImporting"
                              helpText={translate('SkipFreeSpaceCheckWhenImportingHelpText')}
                              onChange={onInputChange}
                              {...settings.skipFreeSpaceCheckWhenImporting}
                            />
                          </FormGroup>
                      }