No files found are eligible for import - Property Brothers: Forever Home

Sonarr version (exact version): 3.0.6.1342
OS: Windows 10
Debug logs: https://0bin.net/paste/NvkeY-Pv#jI6T961Y4pGwKrqL240h5YF-AjerZO/+s8BjDqPc4Yl
Description of issue:

I seem to always have this issue with Property Brothers: Forever Home. Sonarr reports that no files are eligible for import, and yet the file is there. I try a manual import and I receive the same error. The issue, according to the log file (see link above) is that it is (to my untrained eyes) seeing the Sample file and ignoring the actual media file.

Error message:


Proof of existence:

that’s not the file erroring out

Media file does not exist: \media-pc\z\files\completed\Property.Brothers.Forever.Home.S06E09.Out.of.the.Time.Warp.1080p.WEBRip.x264-KOMPOST\Property.Brothers.Forever.Home.S06E09.Out.of.the.Time.Warp.1080p.WEBRip.x264-KOMPOST\Sample\sample-property.brothers.forever.home.s06e09.out.of.the.time.warp.1080p.webrip.x264-kompost.mkv

Yes, I understand that, which I why I posited that the system is ignoring the actual media file and seeing the Sample file, instead. However, the Sample file is in the Sample folder, which is not part of the path that it should be parsing.

Any thoughts on this issue? I can provide any further information as needed.

It’s not ignoring it, it’s just processing the sample first, Sonarr processes all video files in the folder and selects the correct one after analyzing them all.

It’s probably failing due to the length of that file and long path support not being enabled.

Start by enabling long path support and we can go from there.

As directed by the linked article, I have added the word value of 1 in the appropriate registry setting. The article also discusses editing a manifest file, but I have no idea where that might live.

That being said, this appears to have solved the issue. Thanks!