No files found are eligible for import Error Synology - Docker

Sonarr version (exact version): 20200409-16
Mono version (if Sonarr is not running on Windows): 5.20.1.34-13
OS: Synology
Debug logs: Import failed, path does not exist or is not accessible by Sonarr
Description of issue: I have installed transmission in Docker behind a VPN following these instructions https://www.reddit.com/r/VPNTorrents/comments/900w78/xpost_rsynology_setting_up_the/

I then installed Sonarr on the Synology (outside docker) and set it up to download tv shows in Transmission. The download works great but it doesn’t rename and move the download to the directory I’ve inputted. I’ve read a few posts but I don’t understand what is being said (sorry I’m new to this!). I have made some suggested changes in the images below but it’s still not working. I would appreciate any help!

Docker volume setting: https://imgur.com/a/prWgoHh
Docker envinment seting: https://imgur.com/a/ozI5tnc
Sonarr Path: https://imgur.com/a/ozI5tnc
Activity tab error: https://imgur.com/a/HPq5b38
Sonarr logs: https://imgur.com/a/6zB6k8F
Synology file permission: https://imgur.com/a/6zB6k8F

I know I must be doing something wrong but I can’t get my head around it! Any help appreciated :slight_smile:

Kind regards
Stuart

Edit: It might be worth mentioning that the ‘Downloads’ folder is on Volume1 and the ‘Television’ folder is on Volume2. Not sure if that makes any difference but thought I should mention it.

Sonarr is running as a “native” package, right? From synocommunity?
If yes:
Your download client running in docker reports the path it knows inside its own container: /Downloads. This path is not known outside, in syno land (the host).
You have to find the corresponding path on your syno, e.g. /volume1/Downloads, and set up a remote path mapping in sonarr.

To find this path, just go to sonarr and do a manual import, and browse to the location where the download is located. Note this path and cancel out of the dialog, you don’t need to actually do the manual import.

Now go into sonarr’s settings, and set up a remote path mapping. In v2 it’s not that clear, but the help texts should get you there.
The main goal is to let sonarr translate /Downloads into /volume1/Downloads so that when the download client reports the first path, sonarr knows to look for the files in the second path.

(
Small remark: neither the sonarr nor mono versions are actually the versions. They’re the package versions from (I assume) synocommunity.
You can find sonarr’s version in sonarr itself, in System > Status (possibly different name in v2). The mono version used by sonarr should also be noted there for convenience.
Second small remark: don’t think it’s needed at the moment for this problem, but do upload log files somewhere (pastebin or something) and link them here in the future when you have other issues. That helps a lot. :slight_smile:
Last small remark: this was a comprehensive question, good job with the screenshots! I’m just a user but I have a support background so I know the pain of getting hundreds “it doesn’t work” questions and one decent question every once in a while…
)

Hi Thirrian, thank you so much for for replying! I’m added mapping but would you mind telling me if it looks right because I’m still not sure it’s working! https://imgur.com/a/c19LUu8
The Host is the address for my Transmission download (minus the port number) and then do I have the folders the right way around?

Well call my Judy! It’s worked!! :slight_smile:
I had to set the host as ‘localhost’ but it’s done the job and moved the show!

Thanks again for the help. I’m so pleased!!