NAS Mapped Drives V3 Not Working (noob)

Sonarr version (exact version): 3.0.6.1196
Mono version (if Sonarr is not running on Windows):
OS: Windows 10
Debug logs:
Description of issue:

I have tried to run the program as a tray ap as detailed in the FAQ, but Sonarr is unable to find the library. I uninstall and reinstall as a service and it finds the library. My movies are located on a NAS not on this system. I have tried to change the logon user for Sonarr in windows services to a user that has permissions. I stop the service, change the user, restart, and Sonarr can’t find the database library again. I change it back to local service and it finds the libraries but I still cannot add a mapped drive or UNC to my folders on the NAS.

I’m a total NOOB and any help is greatly appreciated.

the database or the root folder / library?

those are two different things.

if the database then it’s ownership probably needs to be fixed to be owned by you.
https://wiki.servarr.com/Sonarr_Appdata_Directory

library you’re on the right track as far as user changing.

@bakerboy448

Thank you!