MediaInfo Library could not be loaded

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: TrueNAS Jail running FreeBSD 13.1-P5
MediaInfo version: 22.12 (but rolled back to 22.10 and issue persists)
Debug logs: Ubuntu Pastebin
Description of issue:

Hi all,

Within the last few days, I’ve started getting the warning “MediaInfo Library could not be loaded MediaInfo_New assembly: type: member:(null)”

I’ve tried the more basic trouble shooting steps available to me, but sadly I have no idea what this warning is trying to tell me, other than MediaInfo isn’t happy. It’s incredibly annoying as it means MediaInfo isn’t able to check if files are sample, meaning I have to import everything manually.

Annoyingly I think this coincides with a an update of my Jail from 13.1-P3 to 13.1-P5, but I‘ve restored the jail from a pre update snapshot (at least I’ve got through the motions, it may not be correct) but I’m still seeing the same behaviour. I’ve also started getting an error with my NZBGet post-processing script in a similar timeframe, so this all feels like it ties back to the Jail update.

I’m hoping that the experts here will be able to point me in the right direction for solving my Media Info issue, which will in turn make it clear what else has gone wrong.

Thanks in advance!

1 Like

Got the same message after an upgrade, 13.1-RELEASE-p2 running quarterly.
Have not noticed any odd behaviors though.

I have the same Issue on XigmaNAS - Glowpanel (revision 9642) which is also based on FreeBSD 13.1-RELEASE-p5

Sonar Info:
Package Version: by
Mono Version:

I’ve downgraded libmediainfo and mediainfo to 22.09 and sonarr works again.

For that i needed to remove sonarr and (lib)mediainfo, set Ports to quarterly (see Ports/QuarterlyBranch - FreeBSD Wiki ), installed sonarr again.
locked libmediainfo and mediainfo, got back to the latest Ports stream and started sonarr.

You bloody hero!

libmediainfo was the missing key for me! Although I had rolled back mediainfo, I hadn’t done the same with libmediainfo. Both are on 22.09 now and I’m back up and running.

Doing this had the accidental secondary benefit of getting me back onto the Sonarr release version train, having been on develop and not being able to update Sonarr via pkg.

Two birds one stone

1 Like

Thank you SO MUCH! I was pulling my hair out (what little is left) trying to solve this. Your solution was perfect.

same issue here… I’m running TrueNAS-13.0-U3.1 and the plugin installed a 13.1-RELEASE version. Sonarr starts up and can talk to my downloader but sonarr reports the mediainfo-22.12 is not found. Grr.

Wondering if I should just create my own jail and install mediainfo-22.09, lock it, then install sonarr from a pkg.

ok… here’s what I did to get things running again on TrueNAS-13.0-U3.1 and using a plugin.

  1. in GUI, created a new instance of sonarr plugin. In sonarr, restored the backup from the broken instance. Confirmed that same mediainfo problem exists.
  2. using truenas console, went into the new sonarr jail using “iocage console sonarr2” (my new jail is named sonarr2)
  3. cd /usr/local/etc/pkg/repos and edit iocage-plugins.conf such that url reads “${ABI}/quarterly
  4. pkg delete libmediainfo (this should delete libmediainfo, mediainfo, and sonarr packages within the jail)
  5. pkg clean (this should clean out any old cache files)
  6. pkg update (this will refresh the pkg db to reflect the quarterly feed)
  7. pkg install sonarr (this should install sonarr, and mediainfo-22.09

And that all worked for this month… Feb 2023 :slight_smile:

1 Like

Thank you so much for this. Saved the day!!!

No need to do anything fancy. You can keep your current sonarr install, just go to your /var/cache/pkg, and in there should be the 22.09 (or some older version) of lib(mediainfo).

  • pkg remove -f libmediainfo mediainfo
  • pkg install /var/cache/pkg/libmediainfo-22.09.pkg /var/cache/pkg/mediainfo-22.09.pkg
  • service sonarr restart


That’s did the trick, but in my case was still necessary to configure the repository back from latest to quarterly, because pkg insisted in install libmediainfo 22.12 and not 22.09.

Thank you!

I also had to reconfigure the repository. Just wanted to sum up the exact steps I had to run to do this without having to completely recreate the jail.

  1. Shut down sonar through the web GUI
  2. Access the jail via shell
  3. pkg remove -f libmediainfo mediainfo
  4. cd /usr/local/etc/pkg/repos and edit iocage-plugins.conf such that url reads “${ABI}/quarterly
  5. pkg clean
  6. pkg update
  7. pkg install libmediainfo
  8. pkg install mediainfo
  9. Restart the jail or service sonar restart
1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.