Kill Sonarr task when the exit icon is clicked


#1

When I click the exit icon, Sonarr is bumped up to 125% CPU and doesn’t stop until a force kill. Surely there’s a way to fix this? (OS X)


#2

Going to need logs and the typical support information to troubleshoot…


#3

Sorry I didn’t give more info. I’m not sure which logs would help. There are no errors, nothing looks wrong.
This has been happening since I installed, a few MacOS versions ago. This one is 10.13.5. I have installed the latest Sonar last week. Sonarr stays like this until it’s killed.

Unclutter


#4

When you open a help and support thread it’ll ask for specific information, but if you open a feature request thread asking for help it won’t.

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS:
Debug logs:
(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document)
Description of issue:

In this case we’re going to need trace logs, post them somewhere and link them here.


#5

Sonarr Version 2.0.0.5227
Mono Version 5.2.0.224
MacOS 10.13.5 (but this problem has always been here over a year)

https://drive.google.com/file/d/1bD7vRlaolPuPBFl6hddMpqtoi8sMikVk/view?usp=sharing

What I just noticed is that on subsequent shutdown and launch, which I had to do to get it in the logs, sonarr does shutdown.


#6

You’re going to need to enable trace logging and grab the trace log file, that will show more details in the logs.


#7

I’m sorry, I did enable it. But in order to show the problem, I have to ask the server to stop, then retsart it and stop again. Maybe it reverts to regular after. Will do this tomorrow, thanks for your patience.

I must have forgotten to save the setting. Here it is:

https://drive.google.com/file/d/1-wm6SXOXEYLRFQN3jXOhGuT5TKegEnyg/view?usp=sharing


#8
18-7-8 19:49:09.3|Trace|Http|Req: 83 [POST] /api/system/shutdown
18-7-8 19:49:09.3|Trace|MediaInfo|Read file offset 182711164-183959552 (1248388 bytes)
18-7-8 19:49:09.3|Info|LifecycleService|Shutdown requested.
18-7-8 19:49:09.3|Trace|EventAggregator|Publishing ApplicationShutdownRequested
18-7-8 19:49:09.3|Trace|EventAggregator|ApplicationShutdownRequested -> NzbDroneServiceFactory
18-7-8 19:49:49.1|Debug|ProcessProvider|Found 0 processes with the name: NzbDrone.Console
18-7-8 19:49:49.2|Debug|ProcessProvider|Found 0 processes with the name: NzbDrone
18-7-8 19:49:49.2|Info|Router|Application mode: Interactive
18-7-8 19:49:49.2|Debug|Router|Tray selected

Based on the logs, Sonarr shuts down and is immediately restarted again. Checking the PID after shutting down should confirm that it’s getting a new PID.

How is Sonarr being started when the computer starts?

Once upon a time a plist was the way to do it, which might be respawning it on death.


#9

Interesting. I do not want sonarr to run on startup. It is only started manually by running the app. But I note that mono is running all the time.

Here’s a script called sonarr inside the NzbDrone directory along with the sonarr.app

https://drive.google.com/file/d/1ItoDboP6YHQwDWU9sR6Oxr3IQBKMRKMQ/view?usp=sharing


#10

Yeah, that ships with the package, but doesn’t restart it on stop.

Mono will only run when Sonarr/Radarr/Jackett or another app running under mono is running.


#11

Hmmmm, here mono-sgen64 is started on startup. I don’t see it in the user section of System preferences. But is the fact that it is running related? Or is that just a helper? 'Fraid I don’t know anything about any of this.


#12

On startup is Sonarr actually running? Could also be something else running under mono.

It’s possible there is a plist starting it.


#13

I’ll try to look around for that plist. Actually, the only tiny issue is I have to killl sonarr after using it, but other wise, I love and have donated. Excellent bit of work! If I do,'t kill it, it uses 125% CPU. If I do,'t ask it to stop on the local server, it uses little CPU, but I need it off to stop the VPN. It’s not a big problem, just that I don’t see why this is happening.