Issue certain indexers via jackett

Sonarr version (exact version): 3.0.3.825. (issue had continued for last 3 months worth of daily updates, perhaps longer)
Mono version (if Sonarr is not running on Windows):
OS: win 10
Debug logs: https://pastebin.com/hgdSGz3L
Description of issue:
Screenshot_20200520-105628_Samsung Internet

Hello sonarr gurus. Everything is working pretty well, except this and one other issue.
Problem happens when I try to save the indexer. I have verified the categories are correct. I have this issue with another index as well, but fix one and then see about the other. I isolated the trace log section. I have checked, rechecked all settings, including trying to create a temp to a working indexer, then changing just the url section with same result. Help me identify if this is a query problem or jackett, although when I do a manual search on jackett, it works fine.

Cheers!

Remove 5030 and 5040, LT only uses 5000 (and 5070 for anime)

Thanks for the reply. However, I tried that, but then I get a different error it can’t be contacted. I assume it uses a standard search with those categories.

Edit: I tried it again on a new index, and your are correct. Thanks, glad it was an easy fix.

I have never had an issue having more categories than it supports, am I incorrect and need to make sure each entry is exactly correct?

So what then would an all user for categories? I only use this as a backup as one more option to hopefully grab entries from indexed I don’t use normally for automatic searches.

So strange. Perhaps the error or system should captor this situation?

I wish jackett supported exposing the categories and you could just check off the ones you want to use. Hmm, if it doesn’t, maybe I’ll open an enhancement v request for jackett?
Thanks!

1 Like

I have the same issue. But setting 5000 does not solve the issue.

I made a new indexer. But the message “query successful, but no results where returned from your indexer. This mabey an issue with indexer or indexer category” keeps appearing.

What can I do to resolve this ?

Before re-adding and testing, make sure there are definitely TV show results on - https://www.limetorrents.info/latest100

1 Like

This is interesting, and frankly it helps to understand how to troubleshoot this more in depth for the future, and perhaps others who run into this issue.

I took the GET statement from the LOG, put the API key back in, and tried pasting to a new browser window with category 5000 vs. 5000,5040,5050. The returned information looked identical.

I will try this with a different index to see what it should look like, but it makes me wonder if this error in Sonarr should be changed to allow one to save the index anyway, but warn the categories should be verified?

Jackett fetches all the results from the first X pages of your search term, and translates the site’s specific categories into generic ones (5000, 5030, 5040, etc.). In the case of the test for LT, it uses the latest100 page instead.

Jackett then filters the results for only those which match the categories Sonarr told it to look for (and which you told Sonarr to use). So if there is nothing matching some of the categories, you get nothing back for those ones (in the case of LT, nothing on their site matches 5030 or 5040, so you’ll never get anything back), hence why your two tests look the same.

So long as you include 5000, and there are results which match 5000, you will get results. Although that isn’t always the case for the latest100 page on LT, so I also include 7010 to make sure Sonarr doesn’t think there’s an issue.

This is likely what has been happening during your tests.

If you untick the 3 ‘enable’ options, you can click Save without testing. Then you can edit it, reenable them, and save again without issue (or at least that’s been my workaround so far).

Maybe I didn’t say it right, t test was 5000.vs 5000,5030,5040. Good point about adding the 7010,that makes sense.

I misunderstood your work - around, thanks for clarifying. I’ve used that before, but until there are results you can’t save it seemed to be. But I never thought about adding other categories that I actually don’t care about but gets you by the problem.

I think rarbg was the other one I have a problem with now, I’ll test this further and see if I can get around the problem.

Thankfully ilike2burning for the assist!

Adding category 7010 solved this issue for me. Thanks.