Invalid torrent file specified ---> MonoTorrent.BEncoding.BEncodingException: Could not find what value to decode

Sonarr version (exact version): 3.0.4.1060
Mono version (if Sonarr is not running on Windows): 5.20.1.34
OS: UnRaid 6.8.3
Debug logs: https://pastebin.com/FuJduU3y
Description of issue: I’ve been using Sonarr (v3) with BTN for months now with no problems. Overnight though, I seem to be getting the following error for anything I try to grab.I’ve tried manually grabbing that torrent using the URL, and it works just fine.

Any ideas what might be wrong here? Thanks in advance for the help.

2 Likes

It’s a pity we can’t see the returned HTML here, as it would clarify the actual issue.

This could be a problem with the site, your connection to it (unlikely, given that you can search OK), your credentials (also unlikely, given you’ve been using it fine for months), or your account.

Try signing into BTN in browser (ideally from the same device and IP), make sure there are no unread messages, that your account is in good standing, and that you can download a .torrent file without any additional steps or notifications.

I don’t have an account, so this may be pointless, but double-check that the download URL for the .torrent file follows the format http://broadcasthe.net/torrents.php?action=download&id=(id)&authkey=(ak)&torrent_pass=(tp)

I have already tried all of your suggestions and it’s working as expected.

  • Account is of great standing
  • I can download torrents fine. Via the website it’s an https URL, however, via Sonarr/BTN API it returns the http URL.
  • Downloading via the http URL returned by the BTN API works fine as well.

Is there somehow a way we can get the HTML to display? Or maybe you can point me how to use the API via an online API tool (with the arguments Sonarr uses) to maybe see the HTML response?

Thanks

Sorry, I’ll have to leave that one to the devs here, I don’t know.

If you haven’t already, try removing BTN from Sonarr, restart Sonarr, re-add BTN, and try again.

I’ve actually figured out how to fix this. Changing the API URL in Sonarr from http://api.broadcasthe.net/ to https://api.broadcasthe.net/ did the trick.

4 Likes

Not sure where to change that? You mean editing actual files? In the indexer I don’t see any option to change the URL.
Edit: sorry, advanced settings were hidden (strange I always leave them on). Found it.

Thanks, this got me up and running again today.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.