Indexers Suddenly Unreachable Only In Sonarr

Sonarr version (exact version): 3.0.9.1549
Mono version (if Sonarr is not running on Windows):
OS: Windows 10 64 Bit
Debug logs: sonar.debug.txt - Pastebin
Description of issue: Sonarr has been working fine with no changes to it or my network/computer. A few days back I noticed it was no longer grabbing new episodes. The indexers appear disabled and Sonarr is saying they are unreachable, but Radarr and other programs continue to work fine with the same indexers. There is no VPN in play here. I have tried to clean re-install the client, made sure it’s on the latest version, etc. I need some help narrowing down why this is happening.

I just noticed even when searching for a new show, I get a message "Failed to load search results, please try again.
Search for ‘show name’ failed. Unable to communicate with SkyHook

Has anyone figured this out? I am having the same issue on my Synology NAS.

Having this issue as well, I read some old forum posts that says it might be due to certificates being out of date. I’m not sure this is the case because I can occasionally get results to load if I refresh the page and try again. However my log is full of Protocol Errors when trying to connect to external resources via https.

UPDATE: you are correct its the certs I did this and it worked. (Read link below "Error with Unable…:). Still having problem with one indexer, but I think it’s unrelated.

Sonarr Error: Indexers unavailable due to failures for more than 6 hours: NZBFinder.ws

Anyone else getting this error for NZBFinder?

1 Like

That worked for me thanks a bunch.

For anyone on Unraid using binhex’s, command to use is
cert-sync /etc/ssl/certs/ca-certificates.crt

Awesome glad it worked for you, and you are welcome Venumo!

Does anybody know how to fix this on Windows? I’m not on synology or a NAS, and I don’t use docker. The topic linked appears to only be for fixing the issue on NAS. I disabled cert validation and tried again but even with it disabled, it’s not working.

Yes, for Synology it is pretty much always mono related certs issue, and the fix is listed in the wiki https://wiki.servarr.com/sonarr/installation#synology-mono-ssl-errors

For Windows, the errors in your log seem to be pointing at either a networking issue

System.Net.WebException: DNS Name Resolution Failure:

Or indexer setup issue

/api/v3/indexer/test: 400.BadRequest

Things to try:
Full turn it off and back on again. PC, any and all networking equipment
Try setting up an indexer again. Don’t reuse the settings from Sonarr, get them from the indexer (api URLs, API etc.)
Make sure network is set to Private in Windows Network Settings
Any AV or web security software? Try temporarily disabling to see if that fixes it
Any recent Microsoft updates that coincide with when the issue started? Can try uninstalling those

I did everything suggested and it still will not work. I definitely think this is a Sonarr specific issue for several reasons:

  1. Radarr and other automation programs continue to operate fine on the same machine using the same indexers
  2. Sonarr will not allow me to re-add an indexer right now (it gives me a red icon when trying to save the new indexer)
  3. Sonarr will not even search for new TV episodes because it says it’s unable to communicate with SkyHook.

If it was a network issue or a firewall/antivirus/etc. issue it should be impacting the other programs as well. Even with all security disabled it still happens. Since the connection is hardlined with no router in play, there should be no additional security impacting the machine. I’m lost on what could be happening.

Update to the v4 beta, see if that resolves your issue - Sonarr v4 - Beta

Is the v4 beta for a Synology NAS without Docker? Do I need to install docker since Mono is no longer supported?

As far as I can tell, it hasn’t been ported across by SynoCommunity, so you’d need to use Docker.

Thank you! Updating to v4 beta fixed the issue. I wish I knew why it stopped working, but hopefully it doesn’t recur. At least for now I’m up and running again!