Indexer api delayed compared with web ui

Sonarr version (exact version): latest
Mono version (if Sonarr is not running on Windows): latest available for macOS
OS: MacOS
Debug logs:
Description of issue: I am using nzb.su as indexer. The sonarr api request brings less records compared to when I check the same information in a browser. The api seems to have the information updated 10-15 hours later than the web ui.
Any idea? Might be the indexer, but trying to confirm. Thanks.

Look at the debug logs and you can see the URL Sonarr hits.

I had a look at the lgs and this is what I get:
20-6-7 23:23:00.5|Warn|Newznab|Indexer nab.su rss sync didn’t cover the period between 6/06/2020 7:39:52 AM and 7/06/2020 11:40:17 AM UTC. Search may be required.
How can I trigger an new search?

Thank you.

Are you running Sonarr on a machine that wasn’t online or Sonarr was shutdown for more than a day?

RSS Sync is not search, if you want to search you can do so from several places in the UI, if you just want to search for recently aired things calendar or wanted: missing are probably the best bet.

Hi,

I am running Sonarr on a laptop that I start now and then. It is running in the background so you can say that it can be offline for more than a day. Is this a problem?
Did not have any issues until a couple of month ago.
Some sources don’t come up in the search even if I do it manually. I can find more sources if I search the nab indexer online and not through the API.

Thanks.

Since Sonarr relies on RSS feeds for grabbing new releases, yes that’s a problem. Ideally it runs 24/7 and never misses anything, but it should be able to check RSS feeds every few hours, maybe less during peak times.

Some sources don’t come up in the search even if I do it manually. I can find more sources if I search the nab indexer online and not through the API.

Sonarr can only show what it gets from the indexer, if it’s not getting some results then those results may be in different categories than Sonarr is setup to search or they aren’t linked to the correct series on the indexer for the ID searching is failing.