Import failed, path does not exist or is not accessible by Sonarr: /volume1/video/SabNZB/complete/ Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder

Hi After updating to DSM 7.0 and repairing Sonnar, Sab, and Rad I have this problem the files are being downloaded, renamed, and sorted but not being moved to the correct folder for the show. Could anyone help with this

Switch to docker

The NAS packages are poorly maintained.

DSM7 has broken permissions/ownership for many users.

Some of managed to fix it; others have not.
It’s basic ownership/ permissions that is the cause. How to fix is a Synology / SynoCommunity Issue, not A sonarr one… you may have more luck on those more focused communities

Thanks I will give it a go on Syno forum as I didn’t really grasp docker, Should never have updated

Is there a good Docker guide to setup Rad/Son/Sab

I managed to set up everything through Docker, Everything is working as it was before now, Not sure I really know how I did set it up in the end but it’s fixed. Thanks for your help

Hey PJ

What guide did you use? I am having the exact same issue as you but I already had Nzbget installed with Docker. It’s some weird file permission error that I know is not real because the permissions are the exact same on both folders…

I would watch the Video and then follow the guides posted, I just used the Video as I prefer seeing things rather than reading them but now the documents do make a lot more sense

Sorry to hijack this thread, but I’m getting the same issue, but with the Linuxsever Docker image. Some background…

I run Sonarr, Radarr, Lidarr, Jackett and QBittorrent linuxserver Docker images on a Synology NAS running DSM 7.0. I previously had a fully-working setup when I used the haugene/Transmission-OpenVPN image rather than Qbittorrent, but due to various issues with the Transmission image becoming unstable, I switched to QBittorrent. In getting the original setup working, I ran into the usual issues around mappings inside and outside the docker and making sure the GUID/PGID were correct etc. In switching over to QBittorrent, I thought I had carried over the setup, but I screwed up somewhere and have been tearing my hair out trying to fix things, but unfortunately can no longer see the wood for the trees. I’m 99.9% sure the community will immediately spot the mistake I’ve made!

Current Setup
I have a shared folder volume1/PlexMedia under which I have the various sub-folders for TV, Movies etc. There is also a volume1/PlexMedia/download folder for the downloads. I have a specific user that has full access to the volume1/PlexMedia shared folder and subfolders and the associated PUID/PGID are set as environment variables in each Docker image. The following volume mappings are in place:

  1. PlexMedia/download mounted as /downloads with rw permisions
  2. PlexMedia mounted as /PlexMedia with rw permissions
  3. docker/Sonarr mounted as /config with rw permissions

What Works
All the “arrs” are able to communicate happily with Jackett, pull the requested release and send it to QBittorrent. Qbittorrent downloads the release into the volume1/PlexMedia/download folder but then Sonarr fails to import the release with the error:

Import failed, path does not exist or is not accessible by Sonarr: /downloads/[release name]

I am then able to manually import the release using the Sonarr UI, so the user running the Docker image does have access to the relevant folder. So it’s the automatic import that failing. Something, somewhere is wrong. I read the suggested documentation and couldn’t see the problem, so I’ve concluded I need a fresh pair of eyes on what I need to either check or change. Something’s not right.

I should add that I have the identical setup in Radarr and Lidarr and they also have the same issue of the automatic import not working, which at least means I’m getting things consistently wrong.

If you’re able to help, I’d be extremly grateful. Thank you.

It almost sounds like you’re perhaps running outdated EOL Sonarr v2 with Qbit 4.3+ which are not compatible.

Otherwise the usual download troubleshooting - and docker guides - should help.

Currently all of your downloads will be I/O abusive imports and double space for all seeding torrents due to the poor paths.

1 Like

Bakerboy, you are a genius! Not only couldn’t I see the wood for trees, I wasn’t even in the right wood :laughing:

You were absolutely correct that I was running Sonarr v2 only because I hadn’t seen a notification that there was an updated version available (I had also heard a while back that there were some issues with the early releases of v3). I updated the Docker image to the latest from linuxserver and everything started to work immediately without making any parameter changes. If only things were always as easy as a quick image upgrade. I can’t believe I’ve been sweating over this for so long and the solution to be so simple. Thank you so so much!

You also mentioned “all of your downloads will be I/O abusive imports and double space for all seeding torrents due to the poor paths” but I wasn’t sure what you were referring to?

Docker paths. If you have /downloads that’s a good indicator your setup is not great.

Would the setup within Container Station on Qnap be similar to the setup on Docker/Synology ?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.