Import failed, path does not exist. NZB and Torrent Client Synology setup

Sonarr version 2.0.0.5344:
Mono version 5.20.1.34:
Docker Synology 218+:
Import failed, path does not exist or is not accessible by Sonarr: /downloads/completed/Lovecraft Country S01E01 Sundown [1080p x265 10bit FS92 Joy].mkv:
**After looking at countless other threads and knowing that my problem lies in my paths setup and I have tried numerous attempts to set up my remote path in Sonarr,and I am still unable to figure out why I keep getting countless errors. All of the files currently reside in volume1/Content/Downloads/Usenet/completed/Sonarr and volume1/Content/Downloads/Torrents/completed. Being that I have a torrent and usenet client(nzbget) I have the Sonnar container in the compose set at the path ending at downloads. Please let me know if I should do something differently being that I want Sonarr to see both clients. **:

File structure on NAS:
/volume1/docker/sonarr: /config
/volume1/Content/Downloads/Usenet/completed/Sonarr
/volume1/Content/Downloads/Torrents/completed
/volume1/Content/Collection/TV Shows

Docker Compose:
/volume1/docker/sonarr:/config # config files
/volume1/Content/Collection/TV Shows:/tv # tv shows folder
/volume1/Content/Downloads:/downloads

Sonarr Remote Mappings
host: “localhost”
remote path: /volume1/Content/Usenet/Downloads/completed/Sonarr/
local path: /downloads/

logfile:
https://pastebin.pl/view/b7f9b6df


Additional Information:

  • Information on the log files is here: https://github.com/Sonarr/Sonarr/wiki/Log-Files
  • Make sure debug logging is enabled in settings
  • Post the log file, not a line or two, or just the error from the Logs table
  • Post the full log to hastebin/pastebin/dropbox/google drive or something similar and link it here
  • Do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document
    —>

It would be much easier to just use a single mount for your files in all your containers: /volume1/Content/

OK, I am not entirely sure what that would look like, but I tried and this is the currrent setup.
File structure on NAS:
/volume1/docker/sonarr: /config
/volume1/Content/Usenet/completed/Sonarr
/volume1/Content/Torrents/completed
/volume1/Content/TV Shows

Docker Compose:
/volume1/docker/sonarr:/config # config files
/volume1/Content/Collection/TV Shows:/tv # tv shows folder
/volume1/Content:/downloads

Sonarr Remote Mappings
host: “localhost”
remote path: /volume1/Content/Usenet/completed/Sonarr/
local path: /downloads/

host: “localhost”
remote path: /volume1/Content/Torrents/completed/Sonarr/
local path: /downloads/

Currently Files are in the torrent/completed and usenet/completed/sonarr
They are not moving to TV show folder.

This should do it, being lazy here so the mount might not make sense but it’ll do the trick I guess/hope :slight_smile:

Docker mounts for sonarr:
/volume1/docker/sonarr:/config
/volume1/Content:/volume1/Content

Remote path mappings: remove everything, this should no longer be required.

Designate /volume1/Content/Collection/TV Shows as a new root folder in sonarr, use the mass editor to change all your series paths to use the new TV Shows root folder, and finally delete the /tv root folder in sonarr to clean it up.

/volume1/Content:/volume1/Content

could you explain to me after the colon? I thought “downloads” went here.

The idea is to have the path inside and outside the container to be the same. That will save a lot of headaches with download clients reporting one path and sonarr having to translate to another path (remote path mappings), as well as allowing sonarr to perform a simple move instead of slow-ass copy+delete.

1 Like

I changed as described. I am getting import failed path does not exist errors for shows that I have previously downloaded and that are currently sitting in /volume1/Content/Torrents/completed and /Content/Usenet/completed/sonarr. The error messages are like this:
Import failed, path does not exist or is not accessible by Sonarr: /downloads/completed/Sonarr/Barry.S01E02.Chapter.Two.Use.It.720p.AMZN.WEBRip.DD.5.1.x264-KORPOS-Scrambled

-The error message is showing for an old root folder

I went to series>import and deleted previous root and successfully imported new root folder : /volume1/Content/Collection/TV shows

Current Docker Sonarr:

  • /volume1/docker/sonarr:/config # config files
  • /volume1/Content/Collection/TV Shows:/tv # tv shows folder
  • /volume1/Content:/volume1/Content

I then went to mass editor and successfully changed new root path

Any ideas for what could be causing this are much appreciated…

I

Get rid of the “tv shows” mount in your sonarr docker.

Is your download client running in a docker container as well?

Edit: I’m also going to leave this here, even if your download client is native, it’s relevant to understand docker mounts: https://wiki.servarr.com/Docker_Guide#Consistent_and_well_planned_paths

I have removed the tv show volume from the docker container. The only volume on the docker container is /volume1/content.

Sonarr is still giving me the path does not exist error messages for an old path. I tried to prune volumes as well. Old dl files are in the usenet/completed/sonarr and completed and have not been organized and moved to the collection folder.

Yes, download clients are docker containers. I have seen something similar to the wiki link with the usenet>media type and torrent>media type directories.

I just dont understand where the torrent and usenet process folders (completed, incomplete, etc…) are at that point. How do the files get put in the correct media type folder? Do I link plex to both tv show/movie folders (usenet and torrents)? And how does sonarr know to look into the usenet>tv show and torrent> tv show?

Plex is not running as a docker container.

Ok, so going from the paths in your initial post and the fact that everything is a container:

For each docker container:

/volume1/docker/<container>:/config
/volume1/Content:/data

That’s it, unless there is another mount that is really required by the container, in that case add it as well. Note that /data replaces ALL mounts that have files that need to be shuffled around by the application in the container. So no separate /tv, /download, /movie etc mounts anymore! Fuck those sideways and let them die in a fire.

In /volume1/Content, create directories as needed. Example:

/volume1/Content
      /Downloads
            /Torrent
                  /... (not sure if you need more directories here for torrents)
            /NZB
                  /Complete
                  /Incomplete
                  /...
      /TV
      /Movies
      /... (Books, Music, ...)

These will show up inside a container as /data/Downloads/Torrent for example.

In each application, adjust file paths to start from /data and nothing else.

I am assuming everything either runs as the same user, or the individual users running the containers all have sufficient access to /volume1/Content and underlying files/folders.
If yes, everything will automagically Just Work :tm: because your download client reports to sonarr "hey, I have a file in /data/Downloads/Torrent/series.s01e01.1080p-group" and sonarr can go to its own /data mount, which is actually the same and pick up the file and do its thing.

Hello, sorry to jump in but i’m having the same issue with almost the same configuration.
Synology ds720+
Sonarr:latest in Docker

my actual path configuration in docker is:
/volume1/PlexMedia/ : /data
/volume1/docker/sonarr: /config

but still getting the error:
[Error] DownloadedEpisodesImportService: Import failed, path does not exist or is not accessible by Sonarr: /volume1/PlexMedia/…

download client is set to land files in a subfolder in /volume1/PlexMedia/…

Any clue?

If your download client is reporting a path starting with /volume1, you’re running it as a native package it seems to me. In that case just set up a remote path mapping.
If not, probably best to create your own topic and provide some details on your setup (what runs where etc).

Sorry, I had to take a while off. This was tilting me. I have spent alot of time trying to get this to work.
I tried to give it another go abiding what you said. Sonarr is persisting on trying to look in an old folder that does not even exist anymore.The error messages I am getting are:

Import failed, path does not exist or is not accessible by Sonarr: **/downloads/completed/**Sonarr/Barry.S01E05.Chapter.Five.Do.Your.Job.720p.AMZN.WEBRip.DD.5.1.x264-KORPOS-Scrambled

My docker compose mounts:
/volume1/Content:/data
/volume1/docker/sonarr:/config

My root folder on Sonarr on series editor:
/data/Content/Collection/TV Shows

-I do not have a volume1/downloads folder anymore. I have tried to delete this folder everywhere. I do not know how sonarr knows anything about this folder anymore.

Here are my logs