How to setup and hardlink?

Sonarr version (exact version): 3.0.4.1021
Mono version (if Sonarr is not running on Windows):5.20.1.34
OS: Synology DSM 6
Debug logs: https://pastebin.com/raw/Fh1wxEbg
Description of issue:

I have sonarr+jacket+qbittorent on my nas.

sonarr volumes:
  - /media :/media
  - /docker/sonarr :/config
qbittorrent volumes:
  - /media/downloads :/downloads
  - /docker/qbt :/config
sonarr volumes:
  - /media/downloads :/downloads
  - /docker/jkt :/config

I tried to leave everything by default, but sonarr keeped searching downloads in it’s /downloads dir, so I added Remote Path Mappings
| Host Remote | Path | Local Path |
| qbt | /downloads/ | /media/downloads/ |

After that option and full conteiners restart, everything uploaded from /media/downloads section and stopped working for no reason. Also all series are copied to /media/tv dir, not hardlinked. I checked it by ls -alhi in downloads and tv dirs. Also I tried to delete file from downloads, and its copy continued working.

Added logfile, where I play with one file - deleting and re-downloading it. I also needed to manually import it after download, because it didn’t work automatically.

UID and GID of all outside directories are linked to ‘docker’ user and ‘user’ usergroup.

Something is completely wrong, but I can’t understand what exactly. In setup, described in linuxserver-io docs, only hardlinking did not work, but trying to make setup as it described in servarr wiki got all these problems for me.

Help?

Start with: https://wiki.servarr.com/Docker_Guide

1 Like

Looks like hardlinks worked all the time, and the problem was in understanding which file is a hardlink and which only a copy. To understand that I made hardlink to my video file by hand from container’s terminal and looked closely at resulting file. I have not figured out that the file is hardlink even though I created it. :sweat_smile: