Help with setting up download client on different server


#1

Sonarr version (exact version): 2.0.0.5085
OS: Server 2016
Description of issue: Need help with Sonarr importing downloads that are downloaded on a different server to what Sonarr is running on.

Heres the idea:

Server A has Sonarr installed on, it searches my indexers and then adds downloads to Server B.
Server B has a C drive and a M Drive where all of the media gets downloaded to.

That bit works.

Where im now stuck is that Sonarr knows that the media has finished downloading but cannot see any files that it can import as its looking for M on its local machine and i need it to look at \SERVERB\MediaDownloads or \SERVERB\M$

How can I get it to do this? I did find the “Remote path mappings” but couldnt get it to work as it wanted a local path and the server with sonarr on only has the C drive and that made no sense for me to map that.


#2

Did you take a look at the help text?

The Local Path is the path Sonarr needs to use to access it, in this case \SERVERB\MediaDownloads, Remote path will be the path that the download client reports as the downloaded path.


#3

Hi,

I did and I have tried this, see screenshot: https://puu.sh/yZINy/213ff1d088.png

However it is still not working, and when i go to manual import, it says it cannot find any media to import.


#4

What do the debug logs show?


#5

18-1-12 15:21:37.4|Error|DownloadedEpisodesImportService|Import failed, path does not exist or is not accessible by Sonarr: M:\Criminal.Minds.S13E11.Full.Tilt.Boogie.1080p.AMZN.WEBRip.DDP5.1.x264-NTb[rarbg]

I have found this, although, the server that is running sonarr can access the MediaDownloads share on the other server and is mapped too, working fine?


#6

The IP you used in the Remote Path Mapping for Host matches the Host field for the download client settings in Sonarr?

Based on the error the remote path mapping is not being applied, which means either the Host or the Remote Path is incorrect.


#7

Thank you! i just checked my download client and I had used its hostname, i have changed to IP and its working now!


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.