Hardlink issue (I checked the guides/eeverything seems to be to specification)

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: Unraid v.6.11.5
Debug logs: https://gist.github.com/baazaar1/5b97e9a21ff02306943e1e62eb095c12
Description of issue:
I’m almost positive my mounts are correct.
same user:group for both pgid:99, puid:100 although they run as root (0) when I do docker exec {qbit|sonarr} id.
Sonarr downloads to /data/torrents/tv-sonarr (catagory), but then it moves it, instead of hardlink. And in the logs, it never mentions a failed attempt to hardlink. I have check permissions, set umasks, configured qbit exactly like the guides specify, and checked that I can hardlink thru commands, also filebot has no issue hardlinking. I have spent hours trying to fix this, its driving me insane.

I will legit pay the first person who figures out the issue 20$ for their help. I know it’s not much, but it’s bugging me that much lol

You mentioned guides but didn’t specify which. Since there are many:


And your link for logs 404s

Sonar Debug File · GitHub - ( looks like I left out a character my bad)
I used the information from WikiArr( I read the whole wiki ) - and also referenced Trash-Guides
Edit: Sonarr Trace · GitHub - Here is a trace log at a different time of the the same action with the same file. I looked at other posts about the issue, and it’s supposed to say ref link (or something similliar) failed, or at least mention trying to hardlink the file and it failing, then as a result the file gets moved instead. (I have hardlink option selected in Sonarr, and I also disabled remove from downloader after finished option ) Can I also mention that I had sonarr working perfectly and hardlinking at one point. I think when I set an actual path in qbit for the tv-sonarr category it stopped working. (I made sure to not use a slash (/) in setting the catagory path) And the file does make it to /data/torrents/tv-sonarr, but then gets moved away. I just don’t know what else I can try to fix lol, I fixed permissions, paths, configs lol

What’s your seeding set to in qbit?

https://imgur.com/a/KRgyCzq - here is screenshot of qbit config.
I have it so that seeding gets turned off imediately, just to prevent any seeding conflicts with sonarr. I think there was some mention of this in the sonarr settings under hardlink enable switch. Also I use a private tracker who lets me leech (for a price) so I don’t have to seed if I don’t want.


If you are not seeding, you won’t need or have hardlinks.

I still need hardlinks. There are more uses for hardlinks than simply for seeding files. Seeding is only one of the reasons. And I don’t see why seeding should be a preqesuisite for sonarr to hardlink my files, that is a decision I make in my qbit config. I mean I have filebot make hardlinks with the same settings no problem. I want to prevent moves from occurring within my array. Be able to seed them if I need to on demand, and also so it looks clean inside my Qbit GUI. I guess I’m gonna force seed for like a minute or two, as a work-around but I simply disagree with the reasoning here.
**I’m gonna enable it and see if it fixes the issue, tho I appreciate your help. Thank you!!!

It does seem to fix it. Well I did say I will pay 20$ and I am a man of my word, so if you want the prize, message me where I can send it.

But your setup seems correct, and hardlinks are working from what you’ve described. But only when required. I think it’s more a misunderstanding of the purpose of hardlinks and why/when they occur in this kind of setup.


  • Sonarr tells your download client to download something
  • Your download client downloads your file to your Download folder, A.
  • Then Sonarr moves your downloaded file from your Download folder, A, to your Media (root) folder, B.

This is how it is supposed to work. This move is supposed to happen.

Hardlinks here are so you are not duplicating space between your Download folder A and your Media folder B, while your download client is still seeding from A. It hardlinks A to B. Once seeding is complete, the hardlink is removed and the file just exists in it’s final resting place, your Media folder, B.

I feel u man, well it hasn’t moved it yet, and its been a bunch of hours. Maybe I can modify the functionality myself if it does. It’s honestly very nice, because if I need to seed something for someone later down the line all my files are in-tact. Essentially I like to download stuff manually and automatically, but have it all still linked up in qbit. It also just looks weird because bunch of my files are hardlinked thru filebot, so I want consistency. (did i mention it just prevents unnecessary moves) I guess it makes deleting files a little extra work, but you can one line delete files in Linux that are hardlinked.