Folder is not writable by user sc-nzbdrone

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: DSM 6.2.2-24922 Update 3
Debug logs:

Description of issue:

Sonarr can’t write on my Synology DS213J NAS even though sc-download and sc-nzbdrone has full rw permissions in DSM settings.

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: DSM 6.2.2-24922 Update 3
Debug logs: Not sure how to do this. Sorry.
Description of issue:

I had issues with Sonarr when updating, so uninstalled and then reinstalled. Now I am trying to import existing series on my Diskstation.

Unfortunately each time I try I add the existing file I get the following message: Folder is not writable by user sc-nzbdrone

I have updated the permissions via the steps at

Can anyone point me in the right direction? I had problems with Plex last month and had similar issues. I got around this by playing with Terminal. Unfortunately I have limited knowledge on how to do this.

I’m having the same issue.

Sonarr version (exact version) :
Mono version (if Sonarr is not running on Windows) :
OS : OSX 10.15.1
Debug log (when attempting to select folder for import of series):
19-11-21 09:42:48.0|Debug|Api|[GET] /api/v3/filesystem?path=&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (18 ms)
19-11-21 09:42:50.8|Debug|Api|[GET] /api/v3/filesystem?path=%2Ftheater%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (0 ms)
19-11-21 09:42:52.0|Debug|Api|[GET] /api/v3/filesystem?path=%2Ftheater%2Fmedia%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (118 ms)
19-11-21 09:42:54.3|Warn|SonarrErrorPipeline|Invalid request Validation failed:
– Path: Folder is not writable by user tony
19-11-21 09:42:54.3|Debug|Api|[POST] /api/v3/rootFolder: 400.BadRequest (47 ms)

Description of Issue:
New version of Sonarr won’t allow me to set the path for importing my existing shows. Path is a mounted drive on my NAS. Did not have issues with Sonarr reading and writing to that path until yesterday’s upgrade. Changing permissions on the folders and mount do not help. Running Sonarr as the main user. Every other program, including the previous version of Sonarr, is able to access that folder as the main user. Can read-write to that folder as the main user from the terminal and the finder.

In the new Sonarr, when you click “import existing series” you get a finder-like window that allows you to select folders to drill down to your TV folder. My TV folder is the 3rd one down from the root theater folder. Once I get 1 level down, no additional folders show up. That is at the mount point. If I try to enter the full path manually nothing happens (other than the log errors you see above).

I’ve been scouring the web on this but there don’t seem to be any solutions or tips.

The user has the same name and password on both machines. This morning I went the extra mile of making sure they have the same user id and all folders and files on the NAS are owned by that user. Still getting the same error.

Did a completely clean reinstall. Tried again and got the same problem. This time with trace level logging:

19-11-21 11:12:16.6|Trace|Http|Req: 62 [GET] /api/v3/rootFolder
19-11-21 11:12:16.6|Trace|Http|Res: 62 [GET] /api/v3/rootFolder: 200.OK (1 ms)
19-11-21 11:12:16.9|Debug|Api|[GET] /api/v3/rootFolder: 200.OK (1 ms)
19-11-21 11:12:16.9|Trace|Http|Req: 63 [GET] /Content/Fonts/UbuntuMono-Regular.woff?v=1.3.0
19-11-21 11:12:16.9|Trace|Http|Res: 63 [GET] /Content/Fonts/UbuntuMono-Regular.woff?v=1.3.0: 200.OK (0 ms)
19-11-21 11:12:18.0|Trace|Http|Req: 64 [GET] /api/v3/filesystem?path=&allowFoldersWithoutTrailingSlashes=true&includeFiles=false
19-11-21 11:12:18.0|Trace|Http|Res: 64 [GET] /api/v3/filesystem?path=&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (1 ms)
19-11-21 11:12:18.0|Debug|Api|[GET] /api/v3/filesystem?path=&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (1 ms)
19-11-21 11:12:20.8|Trace|Http|Req: 65 [GET] /api/v3/filesystem?path=%2Ftheater%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false
19-11-21 11:12:20.8|Trace|Http|Res: 65 [GET] /api/v3/filesystem?path=%2Ftheater%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (1 ms)
19-11-21 11:12:20.8|Debug|Api|[GET] /api/v3/filesystem?path=%2Ftheater%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (1 ms)
19-11-21 11:12:21.6|Trace|Scheduler|Pending Tasks: 0
19-11-21 11:12:21.8|Trace|Http|Req: 66 [GET] /api/v3/filesystem?path=%2Ftheater%2Fmedia%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false
19-11-21 11:12:21.8|Trace|Http|Res: 66 [GET] /api/v3/filesystem?path=%2Ftheater%2Fmedia%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (2 ms)
19-11-21 11:12:21.8|Debug|Api|[GET] /api/v3/filesystem?path=%2Ftheater%2Fmedia%2F&allowFoldersWithoutTrailingSlashes=true&includeFiles=false: 200.OK (2 ms)
19-11-21 11:12:23.8|Trace|Http|Req: 67 [POST] /api/v3/rootFolder
19-11-21 11:12:23.8|Trace|DiskProviderBase|Directory ‘/theater/media/’ isn’t writable. Win32 IO returned 50. Path: /theater/media/sonarr_write_test.txt
19-11-21 11:12:23.8|Trace|SonarrErrorPipeline|Handling Exception
19-11-21 11:12:23.8|Warn|SonarrErrorPipeline|Invalid request Validation failed:
– Path: Folder is not writable by user tony
19-11-21 11:12:23.8|Trace|Http|Res: 67 [POST] /api/v3/rootFolder: 400.BadRequest (18 ms)
19-11-21 11:12:23.8|Debug|Api|[POST] /api/v3/rootFolder: 400.BadRequest (18 ms)

Actually did a complete wipe of the system and reinstalled the OS. Tried Sonarr 2 again and getting the same problem: “Invalid request Validation failed: – Folder is not writable by user tony”.

The thing is the destination folder is writable by the user tony. As tony I can go into the target directory on the command line and touch create files and delete them. If it were possible to figure out why Sonarr thinks tony can’t write to the folder while every other app can do it as tony, I think that might help a lot of people.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.