File path and auto rename - unraid, docker, sabnzbd

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows): N/A
OS: Unraid 6.11.5
Debug logs: N/A
Description of issue:
When searching a file, it is send to the indexer, downloaded but not renamed.
Looking at activity > history > hover over the cloud icon it says “Episode grabbed from xxx and sent to sabnzbd”.
Currently I renamed the files by hand, move them to the media folder, but the next problem is the library import where it thinks that the file already exists, so I have to remove the whole series and add it again to recognize the new episodes.

/mnt/user/ → data
/mnt/user/complete → downloads
/mnt/user/complete/tv → sonarr downloads

/mnt/user/ → data
/mnt/user/media/ → media files

I’ve tried this setup guide, but it does not work (since I created my /media folder a while ago, I need to step one path down - /data = /user): Unraid - TRaSH Guides

I would be happy if someone can help a beginner.

After additional hours of try and error, I could still not figure out how to keep the ‘rename’ and ‘move’ working.
It still just goes like this: sonarr, push search → indexer, looking for the file → sabnzbd, collect and download the file → sonarr, shows the progress, can tell when the download is finished → … file sits at the given path.

At System Events it is the same pattern: Scan → Download → Adding queue → Sent to Sab → … nothing

As told at the start post, I created my folder with all the media without the ‘/data/’ layer, so my subfolders look like this compared to the Unraid Trash Guide.

├── download
│   └── complete
│        ├── movies
│        └── tv
├── movies
└── tv

Sabnzbd Settings

/data = /mnt/user/media
> temp = /data/download/incomplete
> download = /data/download/complete
> tv = /data/download/complete/tv

Sonarr Settings

/data = /mnt/user/media
/media = /mnt/user/media/tv
> root fodlers = /media

In Media Management I enabled ‘Rename Episodes’ and ‘Hardlinks’.
I also tried to disable them, change ‘chmod’ value from 755 to 775 / 777 and set the root folder to path /data/tv.
Also I’ve tried different docker apps of sonarr (binhex, linuxserver, ich777, hotios) “hoping” for some miss config inside the app.

In the Log is changed to ‘debug’, searched for fail, rename, move, sab, etc. but could not find a single failure message. It look like the rename not even tried to do something.
Even after an hour of waiting does not change anything.

Since I don’t know what to change, I hope some of you can give tips I could try.

Sonarr Settings

/data = /mnt/user/media

root folders = /data/tv

having /data and /media, even if they originally shared a parent, means sonarr can no longer hardlink or move, only copy (because you made them different volumes)

you got sab right, you just mucked up sonarr with the extra mount and setting the root path under it instead of the other one

with the single volume you get (from sonarrs perspective)
sab downloading to /data/download/complete/tv/showname
and sonarr moving from there to /data/tv/showname
both share the same parent /data, so if enabled it can hardlink, or move, and not have to copy

note - im making the presumption that both sab and sonarr containers are running under the media account and that account has full access to the media folder youre mapping from

only copy (because you made them different volumes)

But it does not even do this, no copy or moving.

I also tried to change the “/data” to “/media” in the docker settings, so that the path would be correct, but after several hours it still not working.

Without these, it’s really anyone’s best guess.

Is the download tracked by sonarr (it’s visible in Activity > queue) while it’s downloading?

The download is tracked by sonarr: series > search > activity > queue > download with progress bar updating every other second > history grabbed.

It look like at system > event the last trigger is “Report for xxx sent to Sabnzbd from indexer yyy xxx”. So no trigger for the rename or move command.

Can you please post debug logs?

Here I grabbed a ‘testfile’ Sonar -
I checked the log after about 30 min. and nothing more about this ‘testfile’.

line 190 shows it being sent to sab

2023-05-03 12:55:38.7|Info|DownloadService|Report sent to SABnzbd. TESTFILE.s11e37.3

line 200 shows sonar did track it initially

2023-05-03 12:55:43.7|Debug|TrackedDownloadService|Tracking 'SABnzbd:TESTFILE s11e37': ClientState=Downloading SonarrStage=Downloading Episode='TESTFILE - s11e37' OutputPath=.

but then theres no more log entries so its like it disappeared from sab.

whats under here /mnt/user/media/download/complete/tv? an _UNPACK_downloadname or _FAILED_downloadname folder? or a downloadname folder with the extracted files?

ie did sab actually finish and kill the job itself? or did something else happen?

you can bump the sab logging up to debug, download the same file again, and then check the logs to see whats going on

whats under here /mnt/user/media/download/complete/tv ? an _UNPACK_downloadname or _FAILED_downloadname folder? or a downloadname folder with the extracted files?

First the _UNPACK_downloadname, after that the downloadname.

ie did sab actually finish and kill the job itself? or did something else happen?

Yes, sab finished the job and in its logs it is sending always status updates to sonarr.
Need to check de debug log from sab.

sonarr doesnt appear to keep track of what it has sent there previously, it just scans what jobs are in the current queue with the appropriate category, so if sab (or a post process) cleans up the completed job out of the history, or youve setup sab to not remember any history, then there wont be anything for sonarr to find.

in the sab config check under switches > post-processing > history retention to see what its set to. if its set to “do not keep any jobs” then maybe shift it to 30 days, or 50 downloads and see if that helps?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.