Failure after attempting to update

Sonarr version (exact version): 3.x Not sure of exact version since I can’t get into it.
Mono version (if Sonarr is not running on Windows):
OS: Docker on unRAID
Debug logs:
Description of issue:

I have been using SABNZBD and the -arr suite for some time. I started out using the Binhex containers. Sometime in 2021, I switched the repository for my existing container from the Binhex source to Linuxserver’s. I’m not exactly sure why I did this, but it might have been because of the major version release around that time and Linuxserver had a preview build of it. I only did this switch with Sonarr.

Fast forward to a couple weeks ago, I noticed that the container was no longer updating and probably hasn’t for some time. This is when I noticed and remembered that the container was pointed to the Linuxserver repository preview build, even though I know it was originally the Binhex container. I pointed it back to the Binhex repo and updated to pull down the new container. After updating, the web UI was no longer available. I didn’t have time to mess with it, so I switched it back to the Linuxserver repo, updated, and everything looked good. “This is a future me problem” I thought.

Fast forward again to today, and future me noticed that nothing has downloaded for any of my monitored shows in the last two weeks. I did a search on one of the shows that are on my calendar and there were indeed episodes that matched the criteria in my profiles that should have downloaded. However, they were all rejecting with the error. “BlacklistSpecification: SQL logic error no such table: Blacklist.” I get this with every single entry for every single show. I can still manually download them, however.

I did some research and apparently this happens when you upgrade Sonarr and then roll back. It seems that when I switched back to the Binhex repo and Sonarr was able to update again, it also updated the database. (So I’m guessing Sonarr was working under the hood even if the UI was busted) And since I had to switch back to Linuxserver’s, it can now no longer properly read the database since it is an older version.

I tried switching back to the Binhex repo again today, but were met with the same results as two weeks ago. An inaccessible UI. Since my database is now unreadable by the previous version, it looks like my only option short of wiping my Sonarr appdata is to figure out how to get it working using the container from the Binhex repo again.

It was likely the move from develop to latest, rather than the change of image source - Sonarr Troubleshooting | Servarr Wiki

Any backups you can restore from with a fresh container?

I just renamed my sonarr appdata folder so the container (latest) would generate a new set. It started up fine.

I then copied the backup folder from the old set of appdata and attempted a restore from the earliest backup I had, which was just from early this month. As soon as I restored, the container went back into the same failed state.

Sounds like you’re just recreating the same issue. You’d need to run a develop container so that the develop backup actually works.

Unfortunately I don’t even remember the path to the develop container it was using anymore. It was one of Linuxserver’s. However, using the binhex/arch-sonarr:v3 repository will allow the container to start up. However, it runs into the issue that the develop container was having with all releases being rejected with the “BlacklistSpecification: SQL logic error no such table: Blacklist" error. I also attempted to run a clean container using the “binhex/arch-sonarr:v3” and restoring from a backup with that. But the error remains.

At this point, I don’t care if I need to scan my whole library again. It’s not that big. I just don’t want to lose any of my settings. SABNZBD settings, indexers, file naming polices, profiles, and such. Is there a way I can export all of those settings to import into a fresh container?


Failing that, while I’ve never tried it, but you could potentially edit the database file in the backup so that it’s just settings, then zip and try to restore from the edited backup.

Hey hey! Container starts up with that one and I don’t get that SQL error every release. Thank you a ton.

Now that it seems I have a functional container, are there any steps I can take to get me onto Binhex’s latest container?

Manually create a new back up. Update the image to linuxserver/sonarr:develop and create another backup. Then update to linuxserver/sonarr:latest and see if that works. If so, create another backup, update to binhex/arch-sonarr:latest and cross your fingers.

Broke after just changing to linuxserver/sonarr:develop

Try going straight to linuxserver/sonarr:latest. Otherwise, editing the backup db would seem to be your best option. Or see if there are other suggestions over the next few days.

That was a no-go as well.
Where would you suggest starting in editing the backup DB? I see a config.xml in the zip, but that’s only a few lines defining the port, branch, etc. I’m guessing the settings I’m after are in the DB itself.

Maaaaaybe New: Renamed Blacklist to Blocklist by RobinDadswell · Pull Request #4572 · Sonarr/Sonarr · GitHub is causing an issue here, not sure.

Take a look at Useful Tools | Servarr Wiki, but if you’re not sure, wait for someone else to take a look at this.

So, since I have a functional instance again, I’ve been catching up on some series. I noticed on some failed downloads (as they sometimes do) those releases were saying “release is blocklisted” as opposed to “blacklisted”, so it seems to have gone through that change just fine. Everything seems to be working just fine with “linuxserver/sonarr:3.0.9-develop.” I am just unable to get an updated container without it breaking now.

I’ll wait to see if anyone else has something to say here. Otherwise I’ll make a backup copy for Sonarr’s appdata, switch to :latest, and try the recovery options in the link you gave.