"Failed to import episode, Destination already exists" When Trying to Import Monitored Episode

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: Synology DSM 7.1.1-42962 Update 5 (Docker 20.10.3-1308) Package by linuxserver.io
Debug logs: sonarr.debug.0.txt · GitHub
Description of issue:

I get the error “Failed to import episode, Destination already exists” when Sonarr tries to import a monitored episode, this doesn’t happen when I use Quick Search or Interactive Search.

I end up with a copy of the file in the correct place but the original file is not deleted. I’m not sure if this is a SABnzbd issue, an issue with the way Sonarr and SABnzbd are interacting, or possibly a permissions issue.

SABnzbd is set to +Delete in Categories and completes this when Quick Search or Interactive Search is used.

Does anyone have any insight they could share?

Destination already exists is a symptom of a previous failure, usually a previous import was aborted/failed and it wasn’t cleaned up properly. Unfortunately these logs don’t show when it first tried to import and failed which makes it hard to say what might have happened.

You could try removing the file from the series folder and letting Sonarr re-process the import to see if it’s successful and if not capture the error.

What I’ve been doing up till now is “Remove From Download Client” and then “Refresh & Scan”, which works fine as the file is already there.

I’m not sure what’s changed, if anything, but I’m no longer getting “Failed to import episode, Destination already exists”. What’s happening now is it’s failing to import in the first place:

[v3.0.10.1567] System.UnauthorizedAccessException: Access to the path ‘/data/usenet/tv/eastenders.2023.05.29.720p.web.h264-failed’ is denied. —> System.IO.IOException: Permission denied


Which seems like an obvious permissions issue. I believed this was only happening when a monitored show grabs a release, but when trying to confirm this by manually downloading the NZB that failed I got the same error.

When I downloaded a different NZB of the same release it completed:


My manual searches do normally complete just fine.

Definitely looks like permissions, make sure the user running Sonarr has read/write access to the files in your download client, either by using the same user or using the same group and ensuring the group has permissions.

There wouldn’t be a difference between RSS grabbed and manually grabbed releases.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.