Failed to get runtime from the file, make sure mediainfo is available

**Sonarr version (exact version): 2.0.0.5338
**Mono version (if Sonarr is not running on Windows): 6.4.0.198
OS: OSX 10.15.1
Debug logs: https://hastebin.com/liyugibuze.rb
Description of issue:
Sonarr finds shows and hands them off to SABnzbd which then downloads them. When Sonarr attempts to import them it fails with the above debug log. I’ve tried uninstalling Sonarr and Mono completely and doing fresh reinstalls. I’ve rebuilt the Sonarr configuration from scratch (via the Sonarr UI). It runs as ‘tony’. I’ve successfully used tony to create files down in the folder where this file is located. Every folder and file in the path is rw. chmod 777 has no effect on the issue. SABnzbd also runs as tony and has no problem accessing the folder an writing to it. This is happening across all files that get downloaded.

I just tried updating Sonarr’s libmediainfo.0.dylib file with v.19.09 from https://mediaarea.net/en/MediaInfo/Download/Mac_OS. Stopped Sonarr, backed up the file that came with Sonarr, and replaced it with the freshly downloaded one.

Same results.

I also tried running the MediaInfo app on the same machine. It works fine. So that would seem to indicate it’s not a problem with the lib. Unless the app is using a later version of the lib than they make available as an independent file.

It might also help to note that these accessibility problems appear to coincide with my recent upgrade to Catalina. I just can’t demonstrate that conclusively. Also, I’ve granted Sonarr system access rights in Catalina’s new scheme. So it should be able to easily access the download directory.

[v2.0.0.5338] System.UnauthorizedAccessException: Access to the path '/Users/tony/Downloads/complete/tv/Silicon.Valley.S06E04.Maximizing.Alphaness.1080p.AMZN.WEB-DL.DDP5.1.H.264-NTb-4P' is denied. ---> System.IO.IOException: Operation not permitted

That’s the only issue I see in the logs. I’m not seeing errors with mediainfo specifically.

It was a long day. I was getting the error in the title but in the process of trying to get clean logs for you the error seems to have changed to the one you replied with. Throughout the day, as I tried different things, the error would change here and there. But the final result was always the same: access denied, and the file doesn’t get renamed or moved.

As I mentioned

  • the entire pathway is drwxrwxrwx@. ~/Download/complete/tv//
  • the files within the final directory are -rw-rw-rw-
  • Sonarr has been given access Full Disk Access in the Security/Privacy settings in System Preferences (I wanted to just give it access to the Downloads folder but a dialog box never popped up and I haven’t figured out how to do it manually, so Full Access seemed like a reasonable short-term option)
  • Sonarr runs as tony
  • SABnzbd runs as tony and can write to those folders
  • when i’m on the command line as tony i can enter and create files in those folders

Any ideas?

This could be an issue with mono 6.4 (they changed a bunch of disk access in mono 6), but beyond that I’m not sure what would cause that error.

Maybe I’ll downgrade mono. Is there a mono version you would recommend?

5.20 should be good.

I tried going to 5.0. But when I tried to restart Sonarr it gave me a dialog box error saying Mono RE had to be 3. or higher. Tried a couple of different versions between 4 & 5 but kept getting the same thing. I just finished downgrading to Mojave. So I’ll reengage in the morning (before I have to start cooking) and see what develops.

Happy Thanksgiving!

5.0 is too low (iirc). As marcus says you need 5.20. Not 5.2 either. The zero at the end matters! :slight_smile: