Downloaded - Importing for infinity

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: Docker / QNAP QTS
Debug logs: attached

Description of issue:
Stuck on “Downloaded - Importing”

Hi Guys,

First post here so please go gentle :slight_smile:

Also a couple of things to pre-face. I have recently switched to the world of NAS (QNAP TS464) and currently running my Sonarr in Docker. Overall I’m quite new to the world of Linux / dockerisation, however I have been running sonarr on my windows server for the better part of two years without any problems.

Problem at hand:

Well, the problem is that sonarr will not import any files and just seems to be stuck on Downloaded - Importing for an eternity and no amount of config and troubleshooting I’ve done seems to be doing the trick.

The Setup:
I have sonarr linked via SABNZBD via an API Key
SABNZBD places finished downloads to the following location:/share/CACHEDEV2_DATA/SABDOWNLOAD

Sonarr then should import to the following shared drive: /Media Storage/

However as mentioned because sonarr is on docker I have a remote path mapped to the following:
Local Path: /Media Storage/

I have tried various different folders and ensured that everyone has a RW access to both Media Storage as well as the SABDOWNLOAD folders however sonarr just seems to idly be stuck at downloaded - importing…

I have tried recreating the docker container and re-doing the volumes as well as downloading the latest version of sonarr but to no avail.

If anyone has any suggestions I would be most welcome.



System.IO.FileNotFoundException: Media file does not exist: /SABDOWNLOAD/The.Leftovers.S01E01.1080p.Bluray.Remux.AVC.DTS-HD.MA.5.1-CRiSPY/The.Leftovers.S01E01.1080p.Bluray.Remux.AVC.DTS-HD.MA.5.1-CRiSPY.mkv

Somehow Sonarr found that this file exists, but it can’t actually access it.

This isn’t at all what Sonarr is seeing from SAB, it’s just getting SABDOWNLOAD.

I’d highly recommended redoing your entire setup, following Trash’s guide to ensure you have a setup that supports hardlinks and atomic moves.

Looks like Trash doesn’t have a specific guide for QNAP, but Synology might be similar enough.