Docker Sonarr - Import failed, path does not exist or is not accessible by Sonarr

Sonarr version (exact version): 3.0.9.1549
Mono version (if Sonarr is not running on Windows): 6.12.0.182
OS: Qnap latest version (TS-230)
Debug logs:
Description of issue:
Thank you in advance to whoever will reply. I installed Sonarr through Docker. I added the folders Download and the folders i have my tv-series installed (each in their own directory) but when i download a torrent through Qbit it doesn’t move the file to the corresponding folder. The error i have is: [Error] DownloadedEpisodesImportService: Import failed, path does not exist or is not accessible by Sonarr: /share/Downloads/tv-sonarr/See.S03E03.1080p.WEB.H264-GLHF. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder .

Although when i had Sonarr via qnap itself it worked to move the files to their corresponding folders.
I checked the users and Sonarr user and also the user i login to Sonarr have rights to rw at these folders. Is there any other setting i have to enable?

Thank you in advance,

Hi,

I have the same problem and I have not been able to find the solution after 2 days of constant tests.

https://wiki.servarr.com/sonarr/troubleshooting#docker-and-user-group-ownership-permissions-and-paths

Hi again,

my problem was that I didn’t have “Remote path Mappings” configured.

Now I have another problem and it duplicates my files. doesn’t move them, just copies them

Then you need to fix your setup to support hardlinks not copies. The linked docker guide covers that. But having two torrent files is expected. Read the QuickStart guide to understand how sonarr works.

Your remote path map strongly implies you’re downloading to your root folder which means a healthcheck is being ignored and that’s not supported as it causes weird behavior including data loss

First of all thank you that waste some time to reply.
Although when i was using Sonarr through the app itself worked without problem and also managed to have the files get downloaded + imported in the right directories, still can’t do it work with Docker Sonarr.
The message i get is:
[Error] DownloadedEpisodesImportService: Import failed, path does not exist or is not accessible by Sonarr: /share/Downloads/completed/House.of.the.Dragon.S01E04.1080p.WEB.H264-CAKES. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder

The user, i am using to enter sonarr, have right to access that directory and also to access my TV Folder when all the series are saved.
I have enabled remote path mappings so that’s not an issue either. Is there any log i can paste here to find out what’s happening?
I have also added in container->sonarr->advanded settings the paths, normally should work now.

Again, review the docker guide and fix your poor and inconsistent paths and permissions.

If you can’t or won’t do that then idk how you expect someone to wave a magic wand and fix your poor setup for you.

No logs are needed as the error is crystal clear. If your remote path map is not being applied then it’s presumably not correct. If it’s the same as your previous screenshot, then your remote path map will not work and has no impact on anything. A remote path map as the docs explain is a dumb find Remote and Replace Local. Your remote path map from the previous screenshot has no relevance to the paths in the error Sonarr is giving nor can I see how anyone can possibly believe it does.

The download troubleshooting article on the wiki has a link to a step by step walk through for how to configure remote path maps. If it’s not being applied but is correct then remove it, restart sonarr, and re add it.

But a remote path map does not fix broken permissions.

May your day be as pleasant as you are since you believe linking you directly to resources that explain your issues is a waste of time.

If i believed it was a waste of time, i wont bother again replying here. Ok for you it’s pretty obvious what is wrong, but for me it’s not and i am writing here to try to find clues. I can’t understand why you are hostile in your last reply.
I will re-read the link you posted, to find what’s wrong, i have done it in the first time but couldnt understand. And yes ty i will try uninstall and install it again, maybe that’s a solution

In any case, as i wrote in my previous post, thank you for your time on this

Uninstall and reinstall will not fix it and almost never does. It certainly does not and will never fix poor inconsistent paths nor an incorrect remote path map.

Again, see the docker guide and fix your poor inconsistent paths. Your paths are exactly what the install instructions , LSIO’s readme, and the docker guide all explicitly say to avoid.

If your download client is not in docker then yea you’ll need a remote path map. Trash has an article with screenshots on as to how set that up.

but for me it’s not and i am writing here to try to find clues. I can’t understand why you are hostile in your last reply.

There’s no clues needed…just see and actually read and follow the linked resources. Then if needed ask specific questions relating to those. Based on the recent information you’ve provided you’ve made no attempt to follow them and did exactly what they said to not do.

Update on this and an advise to anyone having this problem. I uninstalled qbit which is my main app to download, and installed it through Docker via hotio. The import problem was dissapeared (as by having inside docker the sonarr and download client solve the remote path issue), now it works. I read it on the guide and it was helpful.
The only issue i have at the moment is the following: As Alex mentioned above, it also happens to me, that it copies the file when the import is happening and it also keeps the file in downloads. I tried with hardlink option, but didnt solved it.
I searched the guide for hardlinks but it doesnt say something more or i am blind :stuck_out_tongue:
Anyone have an idea what to do?

Based on your previous paths you will have all your imports be slow IO intensive copies and have duplicate space for all torrents

The hardlink option is on by default and should basically never be touched.

Y’all are not getting hardlink because you refuse to make any attempt to read, follow, understand, or ask any specific questions about the docker guide / linked trash guide. Because the choice was made to ignore LSIO’s readme, the docker guide, trash’s guide, and the install instructions to deliberately set bad paths and multiple mounts your set will never support hardlinks until you redo your paths as previously mentioned many times.

Are u like that in ur rl man? i assume everyone around you take big breaths before talking to you. Quit the act, its getting boring

The fix is simple…follow the guides and change your setup to support hardlinks.

Since you seem to have no desire to do that then there’s no further assistance to provide and you can enjoy your duplicates.

May your day be as pleasant as you are

While baker’s approach is severely lacking he is correct that your paths will not support hardlinks, he also must be having a rough day if it’s going as pleasant as he’s been here.

You need to have downloads and your library on the same volume in order to utilize hardlinks. Different volumes in docker regardless of where they point outside of the container are still different volumes. To move a file from /Downloads to /Library/TV requires a copy of the file to be made, in order to support hardlinks you’d need to do something like move downloads to /Library/downloads and mount /Library to the container, this would require changing of the files outside of the container as well.

Regardless of hardlinks working or not, imports from torrent clients where the torrent is still seeding will not move the file, you’ll have two instances of the same file, but with hardlinks they point to the same data.

1 Like

i will try what u suggested, ty for your input

i think that he don’t understand that we don’t understand what we read to fix the problem.
the answer he always have is RTFM. In my case reading the manual does not help much.

Anyway, there is no reason to continue the story with bakerboy. If you check his profile, his account is suspended because of the way he replies i assume. Maybe a bad month for him.
What markus replied, to me it’s understandable, i will try it out this weekend and reply back

Hey Markus, i moved the downloads inside library and now have a folder Library/Downloads/Completed but when the torrent is 100% doesn’t clear the completed folder (although Sonarr moves the file to the correct folder)
To do so, i can do it via QB but what i want to use Hardlink so the file remain within QB and use the version that is moved to the TV-Series folder. Is there any other setting i must enable?
Baker was always mentioning about my paths.

First let me state that it’s on the same volume (i have only one volume anyway) and it’s like i descibed above.

This is how hardlinks work, Sonarr doesn’t move or remove the seeding file from the completed folder (this is what my last paragraph mentions). https://wiki.servarr.com/sonarr/faq#seeding-torrents-arent-deleted-automatically

You can verify that hardlinks are woprking by looking at the ionode for the seeding file and the file in Sonarr’s library, if they match it’s a hardlink.