Couldn't import episode: The file exists

Sonarr version (exact version):
Mono version (if Sonarr is not running on Windows):
OS: Windows 11 Pro
Debug logs: Hastebin
Description of issue: Downloaded files from SABnzbd are failing to import with error message “Couldn’t import episode: The file exists.” This is a fresh install of Sonarr.

Looks like every subsequent import is probably failing with this, but curious what the reason for the original failure was, since Sonarr can’t delete the file from the destination perhaps something to do with permissions on the destination.

Yeah, I don’t see a reason for the failure anywhere in the trace logs. Sonarr can import shows from the network share, and it can add new shows (ie, create show folders and metadata files). So it doesn’t seem like a permissions or access issue.

I tried moving the downloads directory to the network share, so that the Sonarr import is just moving files between different directories on the same share - this import completed successfully.

Also tried having Sonarr import to a directory on the local workstation, instead of to the network share, and the import was successful in this case.

So importing share->share and local->local works fine, it’s just local->share that’s the problem?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.