Configuration host and NAS

Sonarr version (exact version): 3.0.4.1100
Mono version (if Sonarr is not running on Windows): Docker, linuxserver.io image
OS: ubuntu server + Docker

Hello,
can please someone explain me how my setup should be done? I’ll do my best to explain the situation and how I would like it to work.
I have an ESXi host, with an ubuntu-server on it, running docker containers: Sonarr, Radarr, Lidarr, Sabnzbd, and some others.
Then, there is a NAS, that is used for storage only.

The server itself has a mounted 2nd disk that is used for local verification, repair and extract.
So the data is going to /mnt/data/sab/tmp and finally to /mnt/data/sab/complete, including categories movies, tv and music.
That’s working fine. Radarr basically looks for file, shoots it over to sab, sab downloads, extract, done and places is in the folder on the server.
Finally, this file should actually find it’s way on to the NAS.

The only way I had it working fine was if I put absolute paths in categories in sab (like not “movies” only but the path that corresponds to the volume mounted in the docker, that corresponds to the NFS share on the NAS, for instance /data/Movies, which is directly on the NAS), and then sab would extract files directly to the folder on the NAS.
However, that is slow as snail.

What I am looking for is to set it up like this:

  • sab downloads into temp, repairs and extracts into complete (all on the server)
  • Radarr (or SAB?) moves the file, when done, from complete folder on server to the Movies folder on the NAS

One thing I noticed: if I go to Queue, and however over the orange icon, it says:
Waiting to Import
No files found are eligible for import in /data/Movies/Moviename-Folder

/data is the mount of the NAS folder in the Docker (set up as volume in Portainer)

I also tried Remote Path Mapping, however that doesn’t make much sense, only if I use it “wrong”:
The paths, if they are to map to the same folder, are “same”. Because it is the same container. I can only map it “wrong”, as map downloads folder from the SAB to the Movies folder on the NAS.

Does this make sense? Is it doable?

Thank you

The local disk where you have the sab subfolder needs to be available in sab AND sonarr: /mnt/data/
(I would also call it “local” instead of “data” because it’s pretty confusing otherwise).
Both sab and sonarr need permissions to read/write/delete files here.

Sab should not do any renaming/sorting. Moving from its’ own tmp to complete folder is fine.

The /data mount that points to your NAS only needs to be available in sonarr (and radarr, but these are the sonarr forums so… :wink:).

Then it should Just Work™️. At least then I see no reason it shouldn’t.

OK, I changed to /data/sab to /local (sorry, there is no /mnt, that was a path-mistake).
SAB isn’t doing any sorting, but it is downloading into subfolders. Is that correct, or should I make it download to one folder only? I only wanted to separate downloads according to categories set in Sonarr/Radarr/Lidarr.

Permissions:
That seems to be the problem now. I saw it in the log:
2021-2-7 10:07:35.3|Error|DownloadedMovieImportService|Import failed, path does not exist or is not accessible by Radarr: /downloads/complete/movies/movies-folder. Ensure the path exists and the user running Radarr has the correct permissions to access this file/folder

So now I am not sure what I should do. Owner of the folder on the ubuntu machine locally is me. I have set permissions to sab ugo=rwx.
In Radarr/Sonarr I set PGID and PUID to 1000, since that is the ID of my user on the ubuntu machine (“id user”).
Am I doing this wrong, is there a better way? Should I maybe do a group? Make users radarr/sonarr, add to group, including myself, recursively set ugo=rwx to sab folder?
Sorry, but I am a linux noob, so kinda fighting this (but really keen to learn).

Can you post the docker volumes you have in the sab and sonarr containers?

Hm. Seems to be working now. I guess I had to recreate everything. The above folder I noticed is wrong. (not /downloads/complete/movies/ but currently /downloads/complete). Now that I deleted all from queue, and set them to download new, it’s working - at least for first 1-2 downloads. But the permissions now are quite open. I’d like to limit it to only needed. And also do it with groups, like I mentioned above, if possible.
And I’d also like to sort downloads into subfolders - is that something Radarr/Sonarr can work with?

Basically folders and volumes are like this (for Radarr or Sonarr):
“movies_nas”, device :/volume1/NAS-Storage/Movies
“tv_nas” device: :/volume1/NAS-Storage/TV Shows

And in Radarr / Sonarr docker:
[movies_nas] to /movies
/data/sab to /local
[tv_nas] to /tvshows
/data/sab to /local

That is the preferred setting, to have every download into its own subfolder.

OK, and how should I manage the permissions? What concept should I follow?

I have it working now, working myself down the ladder, reducing the permissions until it doesn’t work. And I’ll try separate users and groups, I’m interested if I can make that work.

And one another thing I am bothered by, is that the transfer speeds according to vmware monitoring, are quite lame. I have gbit, and am getting about 400mbit. Really not sure why.
I will be setting up 10gbit to the switch from the server, and 4x RJ45 from NAS to switch, set up to Bond and LACP. Will see if that helps. But this here should already be faster. Any reason?

If I understand it correctly docker has it’s own network on the host, but something is going around double, I’d guess. Because Radarr is in docker, inside network. Radarr, being in 172… is commanding a transfer from local host (virtual machine, 2nd disk, mounted in ubuntu) to the NAS, which is bound as volume in the docker. All transfer that happen on the host, between docker and host should be very fast really, vmxnet3 and nvme, no reason for 400mbit. And then only speed-bottleneck is actually the 1000mbit connection between the host and nas.
Checked the direct connection via NFS, copy command from NAS to server and back, better, about 850mbit. Still not 1000mbit, not really understand why, especially with NFS.