Chmod \ chown not working (SOLVED)


#1

Sonarr version (exact version): 3.0.1.441
Mono version (if Sonarr is not running on Windows):5.18.1.3
OS: mac OS 10.13.6
Debug logs:
(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document)
Description of issue:

Sonarr is not modifying the user,group or permissions when it copies the files over to my server.
It downloads them on my renames and then copies over to my Ubuntu server.
Its assigned with ‘nobody\nogroup’ and 600 permissions.

In Media managemet I think I have everything set correctly (Screen shot below)

The uid and gid is what I got returned for id -u [username] and id -g [groupname]
Also confirmed this from webmin.

I am seeing in the log files the following:
[v3.0.1.441] NzbDrone.Mono.Disk.LinuxPermissionsException: Unknown group: shaun
19-4-21 11:34:42.9|Debug|DiskScanService|Unknown group: shaun


#2

chown doesn’t work that easily. Only root can do it, and especially tricky remotely.

Given that you’re copying remotely, the permissions need to be dealt with there and depends on how you mount the ubuntu share. In all likeliness your mount is configured to use the nobody:nogroup and those 600 permissions. So you should focus your efforts there. It’s normal linux stuff and really not Sonar specific.


#3

Thanks, that was the gentle nudge I need to figure out the problem.

Before I setup Sonarr I had connected to Ubuntu using guest access (totally forgotten)
when I tried connecting using my username it was rejected, Needed to set smbpasswd

Now I’ve done that I can remotely connect to Ubuntu using the right login and Sonarr is now creating the folders with the correct user.

Thanks again Taloth


closed #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.