Can not add new series

Sonarr version (exact version): 4.0.5.1710
Mono version (if Sonarr is not running on Windows): Unraid binhex-sonarr
OS: 6.12.10
Debug logs: PrivateBin
Description of issue:

I can no longer add new series to sonarr. Not sure how long this has been an issue because I haven’t tried adding anything in a while. Everything else is working as expected, pulling existing series and episodes.

When I search for a new series, the page will pull up but when I click the green “add series” button, it will spin and stay green without adding the series. I’ve tried a few different series with the some result.

Any help would be appreciated.

[v4.0.5.1710] System.ArgumentException: value [/media/Unraid TV/Waterloo Road /]  is not a valid *nix path. paths must start with / (Parameter 'path')
   at NzbDrone.Common.EnsureThat.EnsureStringExtensions.IsValidPath(Param`1 param, PathValidationType validationType) in ./Sonarr.Common/EnsureThat/EnsureStringExtensions.cs:line 119
   at NzbDrone.Common.Extensions.PathExtensions.CleanFilePath(String path) in ./Sonarr.Common/Extensions/PathExtensions.cs:line 41
   at NzbDrone.Common.Extensions.PathExtensions.PathEquals(String firstPath, String secondPath, Nullable`1 comparison) in ./Sonarr.Common/Extensions/PathExtensions.cs:line 59
   at NzbDrone.Common.Disk.DiskProviderBase.<>c__DisplayClass55_0.<GetMount>b__0(IMount drive) in ./Sonarr.Common/Disk/DiskProviderBase.cs:line 466
   at System.Linq.Enumerable.WhereListIterator`1.MoveNext()
   at System.Linq.Enumerable.MaxBy[TSource,TKey](IEnumerable`1 source, Func`2 keySelector, IComparer`1 comparer)
   at NzbDrone.Common.Disk.DiskProviderBase.GetMount(String path) in ./Sonarr.Common/Disk/DiskProviderBase.cs:line 475

The issue is an invalid path is preventing them from being added, either revert to the previous version fixing the path and updating again or edit the path in a SQLite editor and restart Sonarr.

Thanks! I was able to revert to the last version (4.0.4.1491-1-01) and restored a backup I had from that build. After that I was able to add new shows but when I updated to the newest version, the problem came right back up. Currently rolled back to the last version again.

You need to fix those invalid paths before updating or it will keep occurring (until the next release).

Unfortunately, I wouldn’t know where to begin to fix the path.

Just so I understand correctly, do you think the problem is with the docker build in general or something on my end specifically?

The path is in your Sonarr database. Edit the series, change the path and have Sonarr move the files (or move them outside of Sonarr).

1 Like

Thank you for the explanation, I wasn’t understanding originally. I was able to rename the series folder and that did fix the issue. Updated to the newer version and all is working well. I appreciate the assistance!