Bug? Multiple downloads for same Show, blocked my usenet index acct

Sonarr version (exact version): 3.0.3.896
Mono version (if Sonarr is not running on Windows):n/a
OS: win 10
Debug logs: problem with Torrent: https://pastebin.com/yTYuVUFr
I have similar problem now that I added Usernet/indexers which flagged my account (pending)
Description of issue:

when I clicked on Search Selected on the first page of wanted, I noticed the app was talking a LONGGGGGGGGG time. Looking at the bottom-left status I noticed the same Show (SxxEyy) kept showing up… (huh??)

All I can tell from the logs, it has something to do with my indexers having a minimum seeds set to 8. It might have something to do with search results selected have a different SxxEyy download than what was intended, somehow. These are shows that are not in XEM and the mappings are all borked. But I want them anyway, shouldn’t matter if I want a show , it should still work. In any case, there is NO reason the same queue item to be processed over and over!

debug logs were attached.

now the plot thickens:
The day after getting this log, I decided I had enough with daily maintenance of torrents that end up with seeds =0 or seeds that never seed. A friend suggested that was why they switched to using usenet to download, so I finally bit the bullet and subscribed to a news feed, an indexer(s) and went ahead and set things up.

Today I got an email from indexer that my account was flagged: "account has been flagged.

Our system has noticed a high number of grabs per release getting downloaded. This would indicate an issue with your automation software which requires investigation.
"
going to Sabnzb, I saw this:

and

I noticed one of the shows was the same show I saw Sonarr trying to download over and over.

I got permission from indexer to reenable my account so I can turn on debugging and grab new logs to add to this post.

so TO BE CLEAR: the log file attached is BEFORE usenet was enabled, but I saw in the logs repeated attempts to grab the same show over and over. I will add the logs with the usenet/.indexer runaway shortly. I wanted to get this post up to begin the problem solving.

Thanks in advance for your help, I need someone with the source code who can help decode what is going on here.

cheers!

EDIT:
Suggestions for troubleshooting?
would it be best to: start with torrents problem first, disabling the newsfeed indexers for now and blacklist the files in the queue, and have it search for these shows with debug enabled? try to fix this first, once identified, then reenable usenet and try to troubleshoot this next?

Anyone with any ideas? I’m I alone with this issue?

How many others are searching both torrent and usenet?

Looking up old series that likely have bad translation between filenames and show numbers (not in xem)… How do these get fixed?
Thanks all

under config > settings > download clients

set your usenet client options for both recent and older to paused
image

set your torrent client option for add paused to be ticked
image

those will at least stop the stuff from actually downloading while youre testing and gathering logs - dont forget to put them back to what you had when youre done testing

as to why its happening i have no idea, but does it happen if you auto search on a single episode as well? or is it just when you do that search selected option?

Are you using preferred words?

I don’t see anything in the logs you linked where a release was accepted, I assume these were grabbed some time after.

Rhom - good idea, I will reset everything and gather new logs. I tried resetting things and I didn’t see this behavior, but I just had a brown-out and I went to reset things, and saw this in the queue:


partial debug logs for RI s5e6 : https://pastebin.com/QzLr3vbD
partial debug logs for RI s13e4 : https://pastebin.com/QzLr3vbD

here is logs from Sonarr:

So some questions:

  1. I changed some settings in sabnzbd to try to 1) enable logging - 2) stop duplicates from downloading ( detect duplicate downloads - set to fail job, move to history, detect dupe episodes in series I left to off - i changed this to fail - move to history )

I used to have history of what was downloaded, but I don’t see this now in sab. I’m looking through settings to see what I did to remove these, as I wish to have the history.

(edited) I am using no preferred words, but i had a profile preferred set to give certain audio versions a preference, but I checked and the values were all set to 0 due to a previous issue I neglected to put back.
I disabled this preferred section.

In the debug log, I see this scrap in the following debiug log, if it helps:
20-7-17 17:28:18.2|Debug|Parser|Parsing string ‘Restaurant.Impossible.S05E06.720p.HDTV.x264-d0rks’
20-7-17 17:28:18.2|Debug|Parser|Episode Parsed. Restaurant Impossible - S05E06
20-7-17 17:28:18.3|Debug|Parser|Language parsed: English
20-7-17 17:28:18.3|Debug|QualityParser|Trying to parse quality for Restaurant.Impossible.S05E06.720p.HDTV.x264-d0rks
20-7-17 17:28:18.3|Debug|Parser|Quality parsed: HDTV-720p v1
20-7-17 17:28:18.3|Debug|Parser|Release Group parsed: d0rks
20-7-17 17:28:18.3|Debug|Parser|Parsing string ‘Restaurant.Impossible.S05E06.720p.HDTV.x264-d0rks’
20-7-17 17:28:18.3|Debug|Parser|Episode Parsed. Restaurant Impossible - S05E06
20-7-17 17:28:18.3|Debug|Parser|Language parsed: English
20-7-17 17:28:18.3|Debug|QualityParser|Trying to parse quality for Restaurant.Impossible.S05E06.720p.HDTV.x264-d0rks
20-7-17 17:28:18.3|Debug|Parser|Quality parsed: HDTV-720p v1
20-7-17 17:28:18.3|Debug|Parser|Release Group parsed: d0rks

Bump - I keep seeing repeats that I have to pause manually.

I suppose the solution is to enable check for duplicates for downloads and series. This is a band-aid at best.

There isn’t anything in the logs I can find.

I do have a question /observation

If something is downloading, it still shows in wanted on sonarr. So if you run a search for items there, it will try to download it again. I would write this off as my problem, but I had dozens and dozens of the same download. I saw the app trying to search the same show over and over. It was kicking out because of some filter /release, and kept trying. It might have something to do with the crap mapping of discovery specials which throw off seasons.

Sonarr has a bug, no idea how to help identify or fix it…

It should definitely be seen as in queue and rejected if it’s the same release, debug logs will show that behaviour, unless there is some sort of preferred words shenanigans happening (which will again be in the debug logs).

Debug logs are again posted above. I don’t see any shenanigans. Screen shots tell the story, debug logs don’t seem to explain much
(edit:) thanks for replying

The logs from your original post don’t show any releases being accepted (which could be sent to the download client after all releases are processed) and the snippet from your later reply is the same.

I’m sure it is frustrating for you as as it for me to keep replying the same thing over and over.

Let me be perfectly clear:

Since the answer is the same, are you suggesting the correct log file was not uploaded, OR is it possible this something else? (bug with not logging, need trace level.)

What has been missing is WHAT I SHOULD DO DIFFERENTLY.? I have tried to ask in many ways the same question so I can get the info needed to move forward, but we are failing to communicate!!

Please answer this: WHAT SHOULD I SEARCH FOR in the log to ensure I upload the correct log, assuming that is MY problem here?? Otherwise we will keep going in circles.

I am not trying to be rude, I am ASKING FOR HELP so I CAN get the HELP I asked for originally.

Make sense??

Any accepted release logs, Release accepted, any rejected release logs Release rejected for the following reasons: (followed by a list of reasons).

Find a log that shows something accepted that shouldn’t have been. Also look at the the history for the episodes you’re having issues with, if Sonarr sees something in the queue it’s not going to grab the same/a similar release again (like you see in your screenshot).

If Sonarr doesn’t show all those grabs in history then one of two things happened:

  1. Sonarr tried to grab it, but the download client said it failed to grab so it tried another release
  2. Sonarr didn’t actually grab it, something else did

The first happens when the download client is rejecting dupes, but then Sonarr will see it in the queue (and log that it failed to grab it, after accepting it), the second happens when someone leaves an old app running that grabs the releases over and over, it happens quite often.