"All indexers are unavailable due to failures": nzbfinder.ws


#1

Sonarr version (exact version): 2.0.0.5322
Mono version (if Sonarr is not running on Windows): 5.2.0.224
OS: Mac OS 10.14.5
Debug logs: https://drive.google.com/open?id=1xol1czdJOj0RWZSr9PU4hD511WakQbIU
Description of issue:

Hello! I’ve been using Sonarr and Radarr for some time with the same indexer (nzbfinder.ws) for quite some time. An issue that always seems to occur in Sonarr is that, after a couple days of stable use, I get an error about “All indexers are unavailable due to failures” in the System->Status page. This issue only happens in Sonarr and not Radarr, even though I am using the same indexer for both.

Does anyone have suggestions for how to fix it? I’ve been manually hitting “Test” in the connection settings every couple days, but this is starting to wear me down. Thanks for your help! I have looked through similar topics in this forum, but nothing has solved the issue.


#2

I’ve just installed Sonarr in the last two weeks and am using the latest v3 and NZBFinder. Not having the issues you describe. Maybe install v3?


#3

v3 would has no changes that should make a difference, but those logs are full of network related issues, which could by why it’s disabled.


#4

I leave my laptop closed on the shelf/sleeping for much of the day. Could Sonarr be trying to perform an RSS sync while the network connection isn’t active/while the laptop is asleep?


#5

If the computer is asleep so is Sonarr. If it’s not actually asleep, but doesn’t have a network connection it could, but that’s not how sleep works.


#6

I see. Am I correct in thinking that Radarr and Sonarr should take similar approaches to checking indexers for new releases? Is it weird that one sees this error but the other does not?

Fwiw, I have a very reliable Netgear Orbi mesh network at home, so I would be surprised that this is due to connectivity issues.


#7

I don’t know what Radarr does, they forked from Sonarr quite a while ago and we’ve made lots of changes since, some of which they probably didn’t do.

It’s definitely a networking issue, I’m not saying it’s the wireless network, but there is something amiss. Try not sleeping the computer for a couple days and see if the issues persist.