XmlException Syntax Error


#46

I wish there were instructions this good on how to solve this for freenas users.
I reported this issue way back at the beginning of the thread. I was able to use the “pkg mono update” command to get it updated. BUT everytime sonarr has an update it breaks it again. This morning I’m seeing the same mono 3.1.0 again. This time that command does nothing.
This issue has been plaguing me for months now. So frustrating…


#48

This worked for me as well.
I would add for Freenas users that aren’t well versed in the command line. (Took me a while to find the instructions on how to edit the file in freenas ssh)
To edit the /usr/local/etc/rc.d/sonarr script you just have to go to that directory and type:
edit sonarr

The editor is pretty self explanatory.

Also after I did this I was able to get sonarr to jump to mono 5.2.0 but now within the freenas gui it looks like the sonarr service is off and it won’t start. I’ve tried clicking on it, and I’ve tried “service sonarr onestart” from ssh. Sonarr is actually running fine but for some reason I can’t get freenas gui to turn the service on.

I’m not sure if that’s why @cholly did the sql reinstall (I didn’t bother with that because after updating the script and a reboot sonarr started right up and the mono had changed) and Frankly if this is how it has to be so I don’t have to worry about sonarr dropping the mono on me; I’ll take it. Thanks @cholly for the explanation and the instructions to get this fixed; Much appreciated.


#49

Will there be a patch to address this? Seems a lot of people having the same issues.


#50

@veridian5 we only provide packages for windows, debian/ubuntu and to some extend osx. Packages for other platforms such as freebsd, qnap, archlinux, unraid etc are provided by third parties and are outside of our control.
It basically boils down to an outdated mono version, not something we can ‘patch’ Sonarr for.


#51

Ok I see. Thanks for the update.

Steps to fix on Freenas:

  • Ssh into freenas
  • Run warden list to get the list of jails
  • Jexec <nameofsonarrjail>
  • Pkg install mono
  • Edit the config file here /usr/local/etc/rc.d/sonarr
  • Change the procname address to:
  • procname="/usr/local/bin/mono"
  • Restart the jail

#52

A post was split to a new topic: The ‘img’ start tag on line 28 position 20 does not match the end tag of ‘div’