Unable to update Sonarr to the latest (3.0.3.938) version

Sonarr version (exact version): 3.0.3.928
Mono version (if Sonarr is not running on Windows): 6.8.0.105
OS: QNAP QTS 4.4.3.1439
Debug logs: https://pastebin.com/J7LazRWi
Description of issue:
Hi,

I am unable to update Sonarr to the latest version using the built-in update feature. I am using this Sonarr package on my QNAP NAS https://www.qnapclub.eu/en/qpkg/652 which starts at v3.0.3.698, and I have updated in the past on this setup without issues, but when I try to go from 3.0.3.928 -> 3.0.3.938 I get ‘update failed’.

My indexers are working fine and I am able to create successful backups. As far as I can tell it’s only the built-in update feature that isn’t working.

If the debug log looks short it’s because I just turned on that level of logging for this ticket, it wasn’t on previously.

Also using the Mono package from the same source as the Sonarr package (qnapclub - don’t think I can post another URL just yet). There is an ‘official’ QNAP package in their App Centre but it’s only version 5.11.0.2.

Thanks for any help!

Well, just tried to update there and it worked!

Had been trying throughout the day yesterday without any success. Think all remained the same on my end, but who knows.

Cheers guys.

There was an issue with the update server that was fixed shortly after it was first reported.

1 Like