Unable to update in GUI

Sonarr version (exact version): 3.0.3.928
Mono version (if Sonarr is not running on Windows): 6.8.0.105
OS: TrueNAS-12.0-RC1
Debug logs: https://pastebin.com/uGRNmc1B
Description of issue: When I click update it just spins and nothing ever happens and it doesn’t update.

I don’t see anything in the logs indicating it failed, unless the update logs show an error it looks good.

20-10-12 11:21:03.8|Debug|mono|Starting mono --debug /tmp/sonarr_update/Sonarr.Update.exe 84195 /tmp/sonarr_update /usr/local/share/sonarr/Sonarr.exe /data=/config /nobrowser
20-10-12 11:21:03.8|Debug|InstallUpdateService|Restarting Sonarr to apply updates
20-10-12 11:21:11.0|Debug|ProcessProvider|Found 0 processes with the name: Sonarr.Console
20-10-12 11:21:11.0|Debug|ProcessProvider|Found 0 processes with the name: Sonarr
20-10-12 11:21:11.0|Info|Router|Application mode: Interactive
20-10-12 11:21:11.0|Debug|Router|Console selected
20-10-12 11:21:11.2|Info|MigrationLogger|*** Migrating data source=/config/sonarr.db;cache size=-10000;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***
20-10-12 11:21:11.3|Debug|MigrationLogger|Took: 00:00:00.1202437
20-10-12 11:21:11.3|Info|MigrationLogger|*** Migrating data source=/config/logs.db;cache size=-10000;datetimekind=Utc;journal mode=Wal;pooling=True;version=3 ***
20-10-12 11:21:11.3|Debug|MigrationLogger|Took: 00:00:00.0131387
20-10-12 11:21:11.5|Info|OwinHostController|Listening on the following URLs:
20-10-12 11:21:11.5|Info|OwinHostController|  http://*:8989/

I know it’s so weird but I refresh the page and it’s still on the old version telling me there is an update available.

What do the updater logs show?

Where are those logs located?

They’re in the same place as the other logs:

image

Or on disk in their own subfolder.

Same for those, everything looks good. At this point it makes sense to update manually and go from there.