Twitter connection no longer working

When setting up the Twitter connect with consumer key, secret, access token and secret you get a prompt:

Using Direct Messaging is recommended, or use a private account.

The same procedure works in Radarr with no errors.

Logs
I can provide as necessary.

System Information

  • Sonarr Version: 2.0.0.5344 - Mar 13 2020
  • Operating System: macOS
  • Mono: 5.18.0.240

I had twitter working just fine but then Twitter banned my account so I had to switch to a new one with new API info. Radarr worked just fine, Sonarr is complaining.

It’s a warning that shows up when you click test, but it won’t block saving.

I can save, sure, but it doesn’t tweet. I’m saving a non-working setup. Test doesn’t tweet, tweets don’t show up when items are downloaded etc.

I also get the error in the logs: NZBDroneErrorPipeline: Invalid request Validation failed:
– Using Direct Messaging is recommended, or use a private account.

I am using a private account. Again, same exact settings work in Radarr. (with no errors in the log)

Is there a file that stores this information? Maybe its not correctly clearing out the older information? I tried deleting that particular notification and setting it up again and that didn’t work.

Twitter working just fine on Sonarr 3.0.3.737, was able to change over all the API info with no issues.

I may just make the switch on my main unit.

I tested 2.0.0.5344 and I get the warning on test, but save works and on grab events are being sent.

But if v3 is working :+1: