"There was an error loading this page" - Series Specific Error?


#1

Sonarr version: 3.0.0.348
Mono version: 5.18.0.225
OS: Synology Docker

Debug logs: Looked through Tracer and Debug logs and I couldn’t find anything relating to this issue that showed up within the logs.

Description of issue: When viewing one specific series, in this case “Japanology Plus”, the webpage returns with an error “There was an error loading this page”. Within the details of the error it states:

TypeError: Cannot read property 'id' of undefined

    in Connect(EpisodeStatusConnector)
    in td
    in TableRowCell
    in tr
    in TableRow
    in EpisodeRow
    in Connect(EpisodeRow)
    in tbody
    in TableBody
    in table
    in div
    in Scroller
    in Table
    in div
    in div
    in div
    in SeriesDetailsSeason
    in SeriesDetailsSeasonConnector
    in Connect(SeriesDetailsSeasonConnector)
    in div
    in div
    in div
    in div
    in div
    in Scrollbars
    in OverlayScroller
    in PageContentBody
    in Connect(PageContentBody)
    in div
    in DocumentTitle
    in SideEffect(DocumentTitle)
    in ErrorBoundary
    in PageContent
    in SeriesDetails
    in SeriesDetailsConnector
    in Connect(SeriesDetailsConnector)
    in SeriesDetailsPageConnector
    in Connect(SeriesDetailsPageConnector)
    in Route
    in Switch
    in Switch
    in AppRoutes
    in div
    in div
    in Page
    in PageConnector
    in Connect(PageConnector)
    in Route
    in withRouter(Connect(PageConnector))
    in Router
    in ConnectedRouter
    in Provider
    in DocumentTitle
    in SideEffect(DocumentTitle)
    in App

This didn’t occur at all with this specific series in Sonarr v2, and I haven’t seen this error in any other series that I have monitoring within Sonarr v3. It seems like a v3 specific issue with Japanology Plus specifically, which is odd. If it helps, I have a lot of episodes that it’s sifting through, over one hundred. But I don’t know if that makes any difference. I’ve tried removing the series and re-adding, and it always ends up with the same error after the initial search through the folder. Any thoughts?


There was an error loading this page
#2

This is fixed in phantom-develop.


closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.