The application can't be opened

Sonarr version (exact version): Version (or latest, upgraded with Homebrew to latest)
Mono version (if Sonarr is not running on Windows):
OS: macOS 10.12.6
Debug logs:
Description of issue:
Sonarr was working fine, but I couldn’t access the sonarr URL. I tried reinstall sonarr first before looking at the logs. Now when I try to open Sonarr I get a message saying “the application can’t be opened”. Tried deleting the db and restoring from multiple backups

18-9-10 23:34:58.7|Fatal|ConsoleApp|Address already in use. This can happen if another instance of Sonarr is already running another application is using the same port (default: 8989) or the user has insufficient permissions

Sonarr is unable to bind to the selected port, is something else using it?
Have you tried rebooting?
Are any mono/Sonarr processes running?

I’ve rebooted multiple times, I don’t believe another instance of sonarr is running since I did not have it setup to start on boot, but is there an easy way to check?

You’ need to check Activity Monitor.

Thanks for the help, but I’m still unable to open the app. I looked through Activity Monitor for Sonarr and Mono. I also rechecked the port I set it to as well as the default port using the command lsof -nP -i4TCP:38081 | grep LISTEN with no results

Nothing I did worked, but I downloaded the new alpha Sonarr v3 - Alpha and Sonarr is working again

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.