System.Net.WebException: Failed to read complete http response (Can't add new series)


#1

Sonarr version (exact version): 2.0.0.5228
Mono version (if Sonarr is not running on Windows): 5.12.0.226
OS: Ubuntu Server 16.04 running sonarr on Docker
Debug logs: https://hastebin.com/axufacuwom.vbs
Description of issue:
Whenever I try to add a new series, right after hitting the " + " button on the series search result, it stays spinning and nothing happens.
This happens on both my home computer running Sonarr on Windows 10 and my Ubuntu Server running Sonarr as a docker container.
Sonarr is reached from inside the network, access to the server from the outside is not enabled.
I’ve chosen to submit the logs from the Docker container as it is a barebones setup, with no indexer even setup yet.
Judging by the error and the fact that happens in two different hosts within my network it looks as if it cannot get the return traffic from the search outside.
The network is behind an ubuntu router and firewall running Iptables, forwarding rules are pretty standard.
Perhaps I’m missing something on the Router/firewall configuration. Although as mentioned before, it doesn’t need to be accessed from outside the network.

Thank you,


#2

It looks like the request to our server is timing out (which would happen after 90 seconds). It’d be something with outbound connectivity, not inbound. Could be something at your network or ISP level.


#3

First of all thank you.
I know the fault is not on your side. I just need some help to figure it out.
So outbound. Could you specify the hostnames I should be hitting? Is it just skyhook.sonarr.tv ?
I seem to hit that one with no issue from within the network. I’ll dive into my network logs to find what am I dropping and where but it would help to know what to look for.
I’ve also noticed that on other threads you ask folks to check if they get stuff when hitting something like this
http://skyhook.sonarr.tv/v1/tvdb/search/en?term=last+man+on+earth from a browser. And I must say I do get the results on the browser just fine.
I’m puzzled.


#4

skyhook.sonarr.tv and services.sonarr.tv are the main ones.

Are you able to test that from the same system Sonarr is running on? (even curl from the same system)

Besides networking you may also want to try mono 5.10, 5.12 has had a number of issues.


#5

Having the exact same issue on a Windows 10 PC and a Raspbian RPI3. I am able to add some shows such as [270915] Peaky Blinders but others fail such as [270261] The Tonight Show Starring Jimmy Fallon. Opening both their skyhook URLs works fine. Maybe some timeout issue with longer running shows? Is there a way to tweak the timeouts? BTW this was working perfectly about a month ago.


#6

Solved by using a VPN. I’m in South America and for some reasong using a VPN with a US IP solved the issue and now I can add the shows that I was previously unable to. Not sure why, but it works.