Syntax errors on FreeNAS 11.1-U5


#1

Sonarr version (exact version): 2.0.0.5228
Mono version (if Sonarr is not running on Windows): 3.10.0
OS: FreeNAS 11.1
Debug logs:
(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document)
Description of issue:

I have happily been using Sonarr for a couple years now. I noticed a while back that no new TV shows were downloading to Plex (thru my FreeNAS server). I looked at Sonarr, and nothing has been pulled for 3 or 4 weeks now. I have looked at all settings and they seem fine. Something seems odd with Sonarr. I go to any show, click to search, and it never finds anything to download for any series. Seems unlikely that there are no viable NZBs available. If I go to the manual search for a show, there are a pile of NZBs there, but it seems something is bad with every single one of them. Just seems unlikely. I have tried this with several series all to no avail. I use CouchPotato for shows and that’s working just fine, so I know my Usenet provider is working. Just curious if I am alone here.


#2

When you do a manual search for an episode, hover over the red exclamation mark for the nzbs/torrents sonarr finds. It will tell you why that download is considered bad. There’s many possible reasons for that, but if it’s all downloads it’s most likely a general setting that may be incorrect so it flags all downloads as bad.


#3

A couple examples of the error messages. These seem to be common for many of them.

Request Failed. POST /api/release: Syntax Error after ‘<!’ characters. http://www.newzbin.com/DTD/nzb/nzb-1.1.dtd Line 3, position 4.

Request Failed. POST /api/release: ‘img’ is expected Line 28, position 108.


#4

Ah crap, my bad. I totally overlooked your mono version in your first post…
3.10 is ancient and causes those kind of errors. You need to upgrade mono, but not all the way to to 5.12.0.266 (that one causes other problems).


#5

Thanks for the reply! I feel dumb but am not sure how to update it. The whole Sonarr installation is a package that is installed as one entity on FreeNAS. They call it a plugin.


#6

Trying to also work this thru the FreeNAS forum, but still no luck on what to do.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.