Synology Unable to connect to indexer - SecureChannelFailure

**Sonarr version **: 3.0.3.750
**Mono version **:5.20.1.34
OS: Synology DSM 6.2.3-25426 Update 2
Debug logs:https://paste.ubuntu.com/p/7nnvZVmq3T/
Description of issue:

Hi, I have been using SickRage but have been tempted over to Sonarr. However I cannot add NZBGeek as an indexers. I get the error Unable to connect to indexer, check logs. The logs shows authentication failure (SecureChannelFailure). I have noticed the same can be seen when trying to check for Sonarr updates. I think this is to do with Mono but I am struggling to figure out how to fix in DSM.

The debug logs show this:

[v3.0.3.750] System.Net.WebException: Error: SecureChannelFailure (Authentication failed, see inner exception.): 'https://api.nzbgeek.info/api?t=caps&apikey=(removed)

I have come across a post somewhere about running the following

sudo cert-sync /etc/ssl/certs/ca-certificates.crt

followed by

set

echo “$MONO_TLS_PROVIDER”

export MONO_TLS_PROVIDER=btls

But I have no idea how to do this in Mono running on DSM. I have tried SSH but with no joy when trying to run these commands.

I have also tried older versions of Mono and Sonarr with the same results. I run everything through VPN but have tried without and still the same.

Any help would be greatly appreciated as I am considering going down the docker route but would need a different NAS to run.

Thanks

1 Like