Sonnar (& Radarr) won't start


#1

Sonarr version (2.0.0.5301 ):
Mono version ( 5.18.0.240 ):
OS: OSX 10.14.3

[Info] Bootstrap: Starting Sonarr - /Applications/Sonarr.app/Contents/MacOS/NzbDrone.exe - Version 2.0.0.5301
[Debug] ProcessProvider: Found 0 processes with the name: NzbDrone.Console
[Debug] ProcessProvider: Found 0 processes with the name: NzbDrone
[Info] Router: Application mode: Interactive
[Debug] Router: Tray selected
[Info] MigrationLogger: *** Migrating data source=/Users/matt/.config/NzbDrone/nzbdrone.db;cache size=-10000;datetimekind=Utc;journal mode=Truncate;pooling=True;version=3;Full FSync=True ***
[Debug] MigrationLogger: Took: 00:00:00.3493852
[Info] MigrationLogger: *** Migrating data source=/Users/matt/.config/NzbDrone/logs.db;cache size=-10000;datetimekind=Utc;journal mode=Truncate;pooling=True;version=3;Full FSync=True ***
[Debug] MigrationLogger: Took: 00:00:06.5908899
[Info] OwinHostController: Listening on the following URLs:
[Info] OwinHostController: http://*:38989/
[Debug] OwinAppFactory: Attaching NzbDroneVersionMiddleWare to host
[Debug] OwinAppFactory: Attaching SignalRMiddleWare to host
[Debug] OwinAppFactory: Attaching NancyMiddleWare to host
[Info] NancyBootstrapper: Starting Web Server
[Debug] BrowserService: non-interactive runtime. Won’t attempt to open browser.
[Debug] QualityDefinitionService: Setting up default quality config
[Debug] NotificationFactory: Initializing Providers. Count 20
[Debug] MetadataFactory: Initializing Providers. Count 4
[Debug] DownloadClientFactory: Initializing Providers. Count 15
[Debug] IndexerFactory: Initializing Providers. Count 12
[Debug] MonoVersionCheck: Mono version is 3.10 or better: 5.18.0.240
Memory around native instruction pointer (0x1020de55f):
0x1020de54f 05 31 d2 b9 01 00 00 00 45 31 ff 41 8b 54 96 28 .1…E1.A.T.(
0x1020de55f f3 48 0f b8 d2 41 01 d7 48 63 d1 ff c1 48 39 d0 .H…A…Hc…H9.
0x1020de56f 77 e9 66 45 89 7e 08 45 85 ff 0f 84 c0 00 00 00 w.fE.~.E…
0x1020de57f 41 0f b7 76 02 41 8a 46 0a 41 c7 46 04 03 00 00 A…v.A.F.A.F…

Native stacktrace:

0   mono                                0x0000000101f6d9f0 mono_dump_native_crash_info + 197
1   mono                                0x0000000101f1e305 mono_handle_native_crash + 183
2   mono                                0x0000000101e91c12 mono_sigill_signal_handler + 46
3   libsystem_platform.dylib            0x00007fff704c3b3d _sigtramp + 29
4   ???                                 0x00000001047eb380 0x0 + 4370379648
5   mono                                0x00000001020deb32 sweep_job_func + 76
6   mono                                0x00000001020ecac6 thread_func + 652
7   libsystem_pthread.dylib             0x00007fff704cc305 _pthread_body + 126
8   libsystem_pthread.dylib             0x00007fff704cf26f _pthread_start + 70
9   libsystem_pthread.dylib             0x00007fff704cb415 thread_start + 13
  • Assertion at mono-threads.c:628, condition `info’ not met

Abort trap: 6

Description of issue: Hi,

After having to reinstall my OS for various reasons I am now unable to launch Sonarr or Radarr for that matter. When originally installed before wiping the OS I had no issues simply following the instructions, but this time round, am struggling and getting the above error when attempting to run it through terminal.

If I navigate to the localhost:38989 (custom defined port due to router issues) after launching Sonarr it will briefly launch the “loading” page, but then drop out and fail to connect and presents the above.

I have tried to search the forums and tried the corrupt DB process as suggested but to no avail.

Any help would be appreciated, as I’m just about at the end of my tether with it now!

Thanks


#2

This can be closed, managed to get it working eventually…

Still interested in what was causing the problem as in the end I just removed both apps and the corresponding .config folders and reinstalled and it seemed to like it.


closed #3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.