Sonarr won't run after each upgrade (master build) - OSX


#1

Hi All,

I’m still continuing to have the same issue, where - after upgrading (did so twice with the two master build updates in the last 2 days) - the install works perfectly, and after the upgrade, Sonarr continues to run perfectly.

However, if I shutdown Sonarr and then re-run it from the app (or reboot), then Sonarr will not run again. I need to re-install it from a fresh download.

This isn’t absolutely urgent, but I’d love to solve it. Anyone have a similar issue and find a solution?

Jon


Sonarr won't start after homebrew update on Mac
#2

Log files of the failing startup would be very helpful, weithout them there isn’t much to go on.


#3

Markus,

Which logs would you like, exactly?

Jon


#4

I have the exact same issue as OP. Sonarr was working fine after the update, then I restarted my computer and now it won’t run. Says “this application cannot be opened” or some such. I’m running Mac OS X, latest released version.

I also have no idea how to retrieve any logs since I cannot load the web interface at all.


#5

Sonarr’s logs, not sure what other logs there would even be.


#6

Ok - I PM-ed all of my log entries for today to you, Markus.

Jon


#7

I was only aware of the “logs” page in the web UI. Can’t seem to find that folder in my file structure either.

Ah well. As Jon said, simply re-downloading Sonarr.app and overwriting the version already in /Applications fixed the issue, seemingly without destroying any data. My series list is still intact and my queue is as well.

Still, “automatic update” definitely isn’t happening on OS X. You have to manually re-download Sonarr.app every time.


#8

In the GUI, there’s various logs that you can look at, so I wasn’t sure…


#9

I didn’t get a PM.


#10

Sorry, it didn’t go through. Now you should have it…


#11

Not seeing any startup issues in the logs. might be something with the actually App (maybe permissions on the files?), getting a list of the permissions now and after an update would help.


#12

I can’t really replicate it since I’m now on the latest version already. Happy to try again if you give me a link for the previous version…

The permissions for the app right now are Read & Write (drwxr-xr-x@ 3 jonbauer staff 102 Mar 17 08:33 Sonarr.app)

Jon


#13

What about NzbDrone.exe (not sure where that lives when using Sonarr.App, but you can check on System -> Status in Sonarr).

As for testing, you can safely downgrade to 2.0.0.3000 - https://download.sonarr.tv/v2/master/windows/NzbDrone.master.2.0.0.3000.osx.zip the check the permissions on upgrade.


#14

I’m having the same problem, although I didn’t do anything with Sonarr. It was running perfectly fine until I rebooted my Mac last night… and now I get an error window saying, App “Sonarr” cannot be opened. I’m running on a 2014 rMacBook Pro and OS X 10.10.3 (public beta).

Strangely enough, I was getting the same error when I first tried to install Sonarr on my 2010 Mac Mini (which is running 10.10.2). I got the same error with CouchPotato, so I chalked it up to some sort of odd incompatibility and went back to just running Sonarr on my laptop (since it worked). But now that it’s not working on my laptop either, I’m frustrated. I feel like there’s something really obvious I’m missing.


#15

Ok, I stopped Sonarr, installed 2.0.0.3000. At that point, here are the permissions:

drwxr-xr-x@ 3 jonbauer staff 102 Mar 18 07:07 Sonarr.app
-rwxr-xr-x@ 1 jonbauer staff 24064 Mar 16 16:06 NzbDrone.exe

Clicked upgrade. Now on 2.0.0.3004.

Permissions:

drwxr-xr-x@ 3 jonbauer staff 102 Mar 18 07:07 Sonarr.app
-rw-r–r-- 1 jonbauer staff 24064 Mar 18 07:56 NzbDrone.exe

Looks like the NzbDrone.exe permissions are different. Is that the problem?

I stopped and tried to re-start Sonarr. Got the same “The application “Sonar.app” can’t be opened.” error.

After downloading and re-installing Sonarr, the final working 2.0.0.3004 permissions are now:

drwxr-xr-x@ 3 jonbauer staff 102 Mar 18 07:58 Sonarr.app
-rwxr-xr-x@ 1 jonbauer staff 24064 Mar 16 21:55 NzbDrone.exe

Jon


#16

Thanks, Jon. I did a fresh install from the website and Sonarr’s working again. Still not working at all on my 2010 Mac Mini… no idea what’s going on there.


#17

Hi Markus, what do you think?

Jon


#18

I think we stumped him!

:smile:

Jon


#19

I’m having a similar problem now on OSX. If I restart Sonarr, sometimes it starts again properly, but often now it won’t relaunch and I have to run it through terminal again (I haven’t tried the proper OSX package yet).


#20

Was working on other things and hadn’t looked at the logs.

We found at least part of the issue, but haven’t found a solution yet: https://trello.com/c/0DUX81QW/973-os-x-package-fails-on-update

This issue is about the Sonarr.App, if you’re having a separate issue please open a new thread.