Sonarr will no longer start after system updates a few days ago - issue with Mono?


#1

Sonarr version (exact version): Version 2.0.0.5228
Mono version (if Sonarr is not running on Windows):Version 2.0.0.5228
OS: Ubuntu 16.04.5 LTS
Debug logs:
(Make sure debug logging is enabled in settings and post the full log to hastebin/pastebin/dropbox/google drive or something similar, do not post them directly here. Post in .txt not .doc, .rtf or some other formatted document)
[Info] RefreshEpisodeService: Starting episode info refresh for: [282670][Narcos]
[Info] RefreshEpisodeService: Finished episode refresh for series: [282670][Narcos].
[Info] DiskScanService: Scanning disk for Narcos
[Info] DiskScanService: Completed scanning disk for Narcos
[Info] ExistingMetadataImporter: Found 0 existing metadata files
[Info] ExistingSubtitleImporter: Found 0 existing subtitle files
*** Error in `mono’: double free or corruption (!prev): 0x00007f5ed09007a0 ***
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x777e5)[0x7f5ef03117e5]
/lib/x86_64-linux-gnu/libc.so.6(+0x8037a)[0x7f5ef031a37a]
/lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c)[0x7f5ef031e53c]
/usr/lib/x86_64-linux-gnu/libmediainfo.so.0(+0xc721f)[0x7f5ee48e921f]
/usr/lib/x86_64-linux-gnu/libmediainfo.so.0(MediaInfo_Open_Buffer_Finalize+0x8f)[0x7f5ee4c7f9ff]
[0x41a1684d]

Description of issue:
[This is my first ever post with an issue - be gentle ;)]
So - have been running Sonarr since 2015 with almost no problems (or nothing I couldn’t solve with some sensible Googling).

My logs show that the last time Sonarr successfully started up on my HP Gen8/Ubuntu 16.04.5 build was 5 days ago. I may have ran a apt-get update/upgrade around then (I cannot honestly be certain), but certainly no other changes. Having rebooted server several times, Sonarr clearly isn’t starting any more.

I ran a mono debug, which ended with the following error:
Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
/tmp/mono-gdb-commands.dpbNw9:1: Error in sourced command file:
ptrace: Operation not permitted.

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

Aborted (core dumped)

Looking back up through the same debug, I can see the point at which it failed (I think) and have included it above.

The full mono debug log can be found here: https://www.dropbox.com/s/o16yqqe97bk8k66/Sonarr_debug?dl=0

Any suggestions from the community on next steps to fix this gratefully received.
Thanks.


#2

Which version of mono are you running? Looks like you pasted the Sonarr version in twice.

Looks like it failed trying to open media info, which version of libmediainfo is installed?


#4

Hi Markus,

Thanks for the reply.

I’m running Mono JIT compiler version 5.2.0.224 and MediaInfoLib - v0.7.82.

From browsing a few other forums, someone suggested trying to run /usr/bin/mono /opt/NzbDrone/NzbDrone.exe -nobrowser at the command line and this does seem to get Sonarr up and running. However, upon reboot, it still doesn’t start.

Let me know what you think.
Thanks.

EDIT:

So - ignore my comment above about Sonarr working when I run /usr/bin/mono /opt/NzbDrone/NzbDrone.exe -nobrowser. It looks like it fell over again shortly afterwards with the same error.

Let me know what you think.
Thanks.


#5

Update libmediainfo, that one is years old. Their site has information on adding their own repo which has the newer versions.


#6

Many thanks, Markus. This resolved the issue.

Appreciate your assistance.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.