Sonarr v3 wont start

Hi All,
Hoping someone can help me. I am a hobyist with Linux at it has served me well over the time I have used it, however, I have just had 4x HDD’s fail this month and I lost all my media, including the backups :frowning: (6TB of media gone) Anyhow, I am in the frustrating and sad process of setting everything again and the one thing I did manage to save was my Sonarr backup. I thought restoring that would make it easier than setting it all up again.

I have installed Sonarr on Ubuntu 21.04 and it worked, until I tried to restore the files in the zip file of my Sonarr backup. The article I read was to delete the config.xml & nzbdrone.db* files, including the .db-wal/.db-journal files if they existed and restore the backup files to the same location. Restart Sonarr and it should work. Unfortunately it didnt. I didnt modify the install paths (all a default setup with Linux) however localhost:8989 fails to load. Not sure why! :frowning:

I thought I would try to remove the Sonarr install and install it again. I disabled sonarr.service, removed /etc/systemd/system/sonarr.service and lastly rm -rf /opt/NzbDrone/
Now unfortunately I cannot install Sonarr again. The error I get when I run sudo apt install nzbdrone is:

sudo apt install nzbdrone
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
nzbdrone is already the newest version (2.0.0.5344).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

From here I cannot run the mono --debug /opt/NzbDrone/NzbDrone.exe as i get the following error:

Cannot open assembly ‘/opt/NzbDrone/NzbDrone.exe’: No such file or directory.

I appreciate the error indicates the cause of the problem being /opt/NzbDrone/NzbDrone.exe’: No such file or directory, but my question is, how can I get Sonarr to install again so that I can run the mono command successfully?

Any help would be gratefully appreciated!

Hi All,
I managed to get it to work.
After finally getting version 3 to install, the restore backup option in v3 got it back up and running.
Least something managed to work!!

Ok… it looks like a sort of, kinda, jumped the gun a little while.
While I did get it Sonarr v3 to work, I still wanted it to autostart when Ubuntu was rebooted.
So, I changed the sonarr.service file to the below:

[Unit]
Description=Sonarr Daemon
After=network.target

[Service]
#Change and/or create the required user and group.
User=voodoo111
Group=voodoo111

#The UMask parameter controls the permissions of folders and files created.
#UMask=002

#The -data=/path argument can be used to force the config/db folder
ExecStart=/usr/bin/mono --debug /usr/lib/sonarr/bin/sonarr.exe -nobrowser

Type=simple
TimeoutStopSec=20
KillMode=process
Restart=on-failure

[Install]
WantedBy=multi-user.target

Now, the daemon wont load and localhost:8989 will not load in a browser.
Below is the error I get when I check the status of sonarr.service:

oaded: loaded (/etc/systemd/system/sonarr.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2021-05-30 20:13:39 AWST; 12min ago
Process: 22818 ExecStart=/usr/bin/mono --debug /usr/lib/sonarr/bin/sonarr.exe -nobrowser (code=exited, >
Main PID: 22818 (code=exited, status=2)

May 30 20:13:39 per-plex-srv systemd[1]: sonarr.service: Scheduled restart job, restart counter is at 5.
May 30 20:13:39 per-plex-srv systemd[1]: Stopped Sonarr Daemon.
May 30 20:13:39 per-plex-srv systemd[1]: sonarr.service: Start request repeated too quickly.
May 30 20:13:39 per-plex-srv systemd[1]: sonarr.service: Failed with result ‘exit-code’.
May 30 20:13:39 per-plex-srv systemd[1]: Failed to start Sonarr Daemon.

Anyone any have ideas on what could be the issue?

Don’t do that. You shouldn’t edit it at all, if you need to override things override them properly.

At this point I’d recommend removing Sonarr and re-installing again (after making sure the service file you changed is removed), then override anything you need to change. You should be able to override user/group via the install process.